Author Topic: Bug PtokaX Linux 0.4.1.1 (posix) source  (Read 2459 times)

0 Members and 1 Guest are viewing this topic.

Offline BeN71

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-1
Bug PtokaX Linux 0.4.1.1 (posix) source
« on: 07 January, 2010, 18:51:18 »
Hello, PPK. I find bug in PtokaX Linux 0.4.1.1 (posix) source. When >1000 user login and PtokaX use scripts with lib LuaSocket - PtokaX shut's down.
But if PtokaX not use scripts with lib LuaSocket and  >1000 user login - PtokaX is running.

PtokaX forum

Bug PtokaX Linux 0.4.1.1 (posix) source
« on: 07 January, 2010, 18:51:18 »

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 475
  • Karma: +209/-22
  • PtokaX developer
Re: Bug PtokaX Linux 0.4.1.1 (posix) source
« Reply #1 on: 07 January, 2010, 22:35:46 »
That is not my problem, it is luasocket who is causing crash  ::)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline BeN71

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-1
Re: Bug PtokaX Linux 0.4.1.1 (posix) source
« Reply #2 on: 08 January, 2010, 07:42:15 »
That is not my problem, it is luasocket who is causing crash  ::)
But why VerliHub is running with scripts(with lib LuaSocket) ? It is tested with 3000 user count.

What script(s) are you using?
I tested PtokaX with different scripts(use luasoccet), for example Confirm DNS 1.0 Lua 5.1x [Strict][API 2], DNSLookup 1.0d LUA 5.1x [Strict] [API 2], FeedWatch(RSS) and other scripts.

PtokaX forum

Re: Bug PtokaX Linux 0.4.1.1 (posix) source
« Reply #2 on: 08 January, 2010, 07:42:15 »