Author Topic: LuaSocket 3.0-rc1-rev537  (Read 1346 times)

0 Members and 1 Guest are viewing this topic.

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 475
  • Karma: +209/-22
  • PtokaX developer
LuaSocket 3.0-rc1-rev537
« on: 20 February, 2015, 13:53:53 »
Version for PtokaX 0.5.0.3 build 482 and higher.

Homepage: http://w3.impa.br/~diego/software/luasocket/

Binary: http://www.PtokaX.org/files/Libs-482/LuaSocket-3.0-rc1-2.7z
Binary x64: http://www.PtokaX.org/files/Libs-482/LuaSocket-3.0-rc1-x64-2.7z
Source: http://www.PtokaX.org/files/Libs-482/LuaSocket-3.0-rc1-src-2.7z

Iinitializing:
Code: Lua
  1. local socket = require "socket"
  2. local mime = require "mime"

This will create socket and mime metatable, more is in docs 8)

This lib is compatible with PXLua 5.1.x, 5.3.x ;)
« Last Edit: 08 March, 2015, 18:55:32 by PPK »
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

LuaSocket 3.0-rc1-rev537
« on: 20 February, 2015, 13:53:53 »

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 475
  • Karma: +209/-22
  • PtokaX developer
Re: LuaSocket 3.0-rc1-rev537
« Reply #1 on: 08 March, 2015, 18:55:44 »
Updated 8 feb 2015 - Fixed Lua 5.1 compatibility
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

Re: LuaSocket 3.0-rc1-rev537
« Reply #1 on: 08 March, 2015, 18:55:44 »