PtokaX forum

Development Section => Extensions for PXLua => Topic started by: PPK on 09 August, 2015, 20:10:06

Title: lzlib 0.4-work3
Post by: PPK on 09 August, 2015, 20:10:06
Version for PtokaX 0.5.1.0 build 520 and higher.

Change: It is now using PtokaX zlib.dll, instead of own statically linked one.

Homepage: http://luaforge.net/projects/lzlib/

Binary: http://www.PtokaX.org/files/Libs-520/lzlib-0.4-work3.7z
Binary x64: http://www.PtokaX.org/files/Libs-520/lzlib-0.4-work3-x64.7z
Source: http://www.PtokaX.org/files/Libs-520/lzlib-0.4-work3-src.7z

Initializing:
Code: Lua
  1. local zlib = require "zlib"

This will create zlib metatable, more is in readme :)

This lib is compatible with PXLua 5.1.x, 5.3.x ;)