Author Topic: lzlib 0.4-work3  (Read 2168 times)

0 Members and 1 Guest are viewing this topic.

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 478
  • Karma: +209/-22
  • PtokaX developer
lzlib 0.4-work3
« on: 14 December, 2013, 15:06:39 »
Version for PtokaX 0.5.0.1 build 445 and higher.

Homepage: http://luaforge.net/projects/lzlib/

Binary: http://www.PtokaX.org/files/Libs-445/lzlib-0.4-work3.7z
Binary x64: http://www.PtokaX.org/files/Libs-445/lzlib-0.4-work3-x64.7z
Source: http://www.PtokaX.org/files/Libs-445/lzlib-0.4-work3-src.7z

Initializing:
Code: Lua
  1. local zlib = require "zlib"

This will create zlib metatable, more is in readme :)

This lib is compatible with PXLua 5.1.x, 5.2.x and 5.3.0(work1) ;)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

lzlib 0.4-work3
« on: 14 December, 2013, 15:06:39 »

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 478
  • Karma: +209/-22
  • PtokaX developer
Re: lzlib 0.4-work3
« Reply #1 on: 20 February, 2015, 13:59:59 »
Updated version for PtokaX 0.5.0.3 build 482 and higher.

Homepage: http://luaforge.net/projects/lzlib/

Binary: http://www.PtokaX.org/files/Libs-482/lzlib-0.4-work3.7z
Binary x64: http://www.PtokaX.org/files/Libs-482/lzlib-0.4-work3-x64.7z
Source: http://www.PtokaX.org/files/Libs-482/lzlib-0.4-work3-src.7z

Initializing:
Code: Lua
  1. local zlib = require "zlib"

This will create zlib metatable, more is in readme :)

This lib is compatible with PXLua 5.1.x, 5.3.x ;)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

Re: lzlib 0.4-work3
« Reply #1 on: 20 February, 2015, 13:59:59 »