0.4.2.0 build 316 with final Lua 5.2.0
 

News:

11 April 2017 - PtokaX 0.5.2.2 released...
8 April 2015 Anti child and anti pedo pr0n scripts are not allowed anymore on this board!
28 September 2015 - PtokaX 0.5.2.1 for Windows 10 IoT released...
3 September 2015 - PtokaX 0.5.2.1 released...
16 August 2015 - PtokaX 0.5.2.0 released...
1 August 2015 - Crowdfunding for ADC protocol support in PtokaX ended. Clearly nobody want ADC support...
30 June 2015 - PtokaX 0.5.1.0 released...
30 April 2015 Crowdfunding for ADC protocol support in PtokaX
26 April 2015 New support hub!
20 February 2015 - PtokaX 0.5.0.3 released...
13 April 2014 - PtokaX 0.5.0.2 released...
23 March 2014 - PtokaX testing version 0.5.0.1 build 454 is available.
04 March 2014 - PtokaX.org sites were temporary down because of DDOS attacks and issues with hosting service provider.

Main Menu

0.4.2.0 build 316 with final Lua 5.2.0

Started by PPK, 16 December, 2011, 20:56:30

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

PPK

Final Lua 5.2.0 was released today http://permalink.gmane.org/gmane.comp.lang.lua.general/86552

Windows x86/x64 version with GUI: http://www.ptokax.org/files/0.4.2.0b316-Lua5.2.0.7z


Quote from: Changes from build 314
Added: Both IP addresses to !getinfo command for users with IPv6 and IPv4 connection available.
Changed: Library dependencies linking moved to project files on windoze.
Fixed: Compile with Lua 5.1/5.2 based on actually available Lua lib.
Removed: All info related to old ip-to-country database.
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Black-Dragon

hi Today I gave this to strange error  [ 29/01/2012, 16:22.27 ] [ERR] not enough memory   ??? ??? ??? ???

PPK

That is error from Lua, but i have no idea what script do that he get out of memory  ::)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Black-Dragon

#3
Hi ppk I have no lua in ptokax ptokax is just, I did not put the lua because I was testing the new version of ptokax

stats my server

Cpu Xeon r x3460 @ 2.80 GHz Dual Processor

Ram 2.00 GB

OS Windows Server 2008 Datesenter 64 Bit

PPK

If you don't used lua script then you can't get that message, because only place where is text "not enough memory" is Lua  ::)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Black-Dragon

However with version 0.4.1.2 PtokaX does not give me this error  :-[

PPK

And how is old-stable 0.4.1.2 (with Lua 5.1.4) related to this testing version (with Lua 5.2.0)  ???
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Electrico

I get this error when trying to start the script PxWeb.lua

[16:33:45] Syntax error loading module 'lfs' from file 'C: \ 0.4.2.0b316-Lua5.2.0 \ libs \ lfs.dll':
We did not find the specified process.

With version 0.4.2.0 build 314 gives me no problem.

PPK

Libs for Lua 5.1.x are not compatible with Lua 5.2  ::)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Hamachi

Is there any libs for Lua 5.2 on windows ?

Have no problem on Linux, but i need it for Windows too..

SMF spam blocked by CleanTalk