Author Topic: Crash on Debian 6  (Read 2286 times)

0 Members and 1 Guest are viewing this topic.

Offline swee

  • Member
  • ***
  • Posts: 31
  • Karma: +3/-0
Crash on Debian 6
« on: 11 March, 2012, 21:03:27 »
Nice Guide
Ptokax up and runing in no time .
But Ptokax stops working after a few hours. How come ?
I havent found out why.
Some times it will run for 5 hours next time only 1 hour.
the computer doesnt go down during the time.

Any suggestions .
Runing it on Debian 6.
Hope you understand what I mean.
/regards swee

PtokaX forum

Crash on Debian 6
« on: 11 March, 2012, 21:03:27 »

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 475
  • Karma: +209/-22
  • PtokaX developer
Re: Crash on Debian 6
« Reply #1 on: 11 March, 2012, 21:15:31 »
What PtokaX version ? What scripts you are using ? Afaik on debian luasocket is crashing PtokaX  ::)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline swee

  • Member
  • ***
  • Posts: 31
  • Karma: +3/-0
Re: Crash on Debian 6
« Reply #2 on: 11 March, 2012, 22:00:25 »
Sorry forgot.
Tried Ptokax 0.4.2.0 first .
Then whit 0.4.1.2 .
whit the script NoPubHub 1.0f LUA 5.1x [Strict][API 2]

the scripts run whit no problem on a windows machine

Had same problems on both Ptokax versions.

Will it run on Ubuntu  then ?

Thanx for reply.
/regards swee
« Last Edit: 11 March, 2012, 22:08:20 by swee »

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 475
  • Karma: +209/-22
  • PtokaX developer
Re: Crash on Debian 6
« Reply #3 on: 11 March, 2012, 22:23:28 »
scripts
I see only one script in your post. Anyway i'm running my public hub on free VPS with debian 6.0 without problems mostly with uptimes longer than week, most time from one VPS crash to another VPS crash ;D
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline swee

  • Member
  • ***
  • Posts: 31
  • Karma: +3/-0
Re: Crash on Debian 6
« Reply #4 on: 11 March, 2012, 22:43:23 »
Well You are so right it is only one script.  :D
But I will give it a go and try it whitout any script to see if there is any changes.

Is there some issues with some scripts ?
I figured if they are working on an Windows machine they should work on an Linux machine as well.


/regards swee
« Last Edit: 11 March, 2012, 22:47:07 by swee »

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 475
  • Karma: +209/-22
  • PtokaX developer
Re: Crash on Debian 6
« Reply #5 on: 11 March, 2012, 23:25:39 »
Few users reported that script using luasocket causes random crashes on debian  ::)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline swee

  • Member
  • ***
  • Posts: 31
  • Karma: +3/-0
Re: Crash on Debian 6
« Reply #6 on: 11 March, 2012, 23:33:04 »
So I guesss i can remove scripts from causing the problem then.

Hmm makes one wonder what makes it crash.

well maybe i should try another Linux dist then. ::)

/regards swee

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 475
  • Karma: +209/-22
  • PtokaX developer
Re: Crash on Debian 6
« Reply #7 on: 12 March, 2012, 00:15:48 »
You can try to disable script errors loging. I has yesterday crash caused by typo in script, i'm searched what happen and found that in some rare cases this can cause crash  ::)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline swee

  • Member
  • ***
  • Posts: 31
  • Karma: +3/-0
Re: Crash on Debian 6
« Reply #8 on: 21 March, 2012, 17:04:46 »
I have been fighting with this a few days now. And not using any scripts at all.
But whith a clean install I can not get PtokaX to run cause off some error in settings.xml.
So then I took mine from the one i run on windows. started up and run for 2 hours.
then it died again.
in the settings.xml from windows there is not so much in it as in the one for linux.

it looks like this.(the settings.xml from windows)

<?xml version="1.0" encoding="windows-1252" standalone="yes" ?>
<PtokaX Version="0.4.2.0">
    <Booleans>
        <Bool Name="AutoStart">1</Bool>
        <Bool Name="AutoRegister">0</Bool>
        <Bool Name="RegBot">0</Bool>
        <Bool Name="UseBotNickAsHubSec">0</Bool>
        <Bool Name="RegOpChat">0</Bool>
        <Bool Name="MOTDAsPm">1</Bool>
    </Booleans>
    <Integers>
        <Integer Name="MaxUsersPeak">15</Integer>
    </Integers>
    <Strings>
        <String Name="HubName">Fromabove</String>
        <String Name="HubAddress">172.16.16.245</String>
        <String Name="TCPPorts">411;1209</String>
        <String Name="HubTopic">Share as U wishl</String>
    </Strings>
</PtokaX>

Is the Ptokax stopping cause of to little in the settings or to much with a clean install.
if so what is needed to make it run with as little as possible ?
and yes I know the hubaddress should probably be an dns adress  :-[

/regards swee



Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 475
  • Karma: +209/-22
  • PtokaX developer
Re: Crash on Debian 6
« Reply #9 on: 21 March, 2012, 18:12:34 »
Use GDB to get reason of crash... ::)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

Re: Crash on Debian 6
« Reply #9 on: 21 March, 2012, 18:12:34 »