Author Topic: Libs issues with ptokax 0.4.1.2  (Read 2461 times)

0 Members and 1 Guest are viewing this topic.

Offline TZB

  • Double Ace
  • *
  • Posts: 119
  • Karma: +13/-1
  • ||-T-z-B-||
    • FastFix Support
Libs issues with ptokax 0.4.1.2
« on: 24 April, 2011, 06:49:13 »
Ok after a lot of waiting i think its time to get this issue posted here.
guys please let me know what is need to be done.
Am not sure if its a bug or its some issue with my libs and setup and i tried fresh install of libs and scripts and download of ptokax done loads of combination but nothing seems to be working.
Scripts using libs are not starting
DiXbot, Freshstuffs,Funscript.
ptokax for Windows 32 bit. 0.4.1.2
Quote
[10:17:59 AM] Syntax error loading module 'pxlfs' from file 'D:/0.4.1.2b26/scripts/freshstuff/lib/pxlfs.dll':
   The specified procedure could not be found.
<-- freshstuffs Script when clicked to start

Quote
[10:18:34 AM] Syntax error loading module 'pxsocket' from file 'D:\0.4.1.2b26\scripts\libs\pxsocket.dll':
   The specified procedure could not be found.
<--- Feedwatch script
Quote
[10:20:12 AM] No syntax errors in script file DiXBoT.lua
[10:20:13 AM] Syntax error loading module 'pxlfs' from file 'D:\0.4.1.2b26\scripts\libs\pxlfs.dll':
   The specified procedure could not be found.

[10:20:13 AM] Script started.
<-- Dix bot Script

PtokaX forum

Libs issues with ptokax 0.4.1.2
« on: 24 April, 2011, 06:49:13 »

Offline Psycho_Chihuahua

  • Systemspecialist IT
  • Emperor
  • **
  • Posts: 1 054
  • Karma: +112/-1
  • I am wherever i want to be
    • PtokaX Luaboard
Re: Libs issues with ptokax 0.4.1.2
« Reply #1 on: 24 April, 2011, 09:45:46 »
Well, i had mentioned it to you in one of the hubs before.... The Libs are not working on the latest Development Versions. They do however work on the last Release Version...

But i'll explain it again:

0.4.1.2 - Works without problems
any newer version from this thread - will not work

This is due to the libs being "outdated" (some of them are as old as the hills). Before someone dedicates his/her free time to mess with updating them, we will not be able to use lib based scripts under windows with the latest development ptokax versions (Besides Development Versions are NOT stable one's)

Simple Solution:
Convert over to linux where there are enough libs available via aptitude or yum which do work (which is what i have done)
PtokaxWiki ?PtokaX Mirror + latest Libs

01100001011011000111001101101111001000000110101101101110011011110111011101101110001000000110000101110011001000000101010001101111011010110110111101101100011011110111001101101000

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 475
  • Karma: +209/-22
  • PtokaX developer
Re: Libs issues with ptokax 0.4.1.2
« Reply #2 on: 24 April, 2011, 10:46:58 »
Before someone dedicates his/her free time to mess with updating them
And PPK will not mess with them because PPK know that Lua lib in development will be changed again few times (is possible that Lua 5.1.5 will be released) before next stable release :P
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

Re: Libs issues with ptokax 0.4.1.2
« Reply #2 on: 24 April, 2011, 10:46:58 »