PtokaX forum

PtokaX => Bugs => Topic started by: nikita800 on 27 June, 2007, 06:18:39

Title: Error RegisteredUsers.xml
Post by: nikita800 on 27 June, 2007, 06:18:39
The hub has worked more than 30 days. Yesterday the hub has broken :) Here a broad gully. Most likely it because of file RegisteredUsers.xml as if it to remove, the hub works. The size of this file has already reached 939Kb
---------------------------26.06.2007 10:49:15---------------------------
Exception 'EAccessViolation' in module PtokaX.exe at 001B92DF
Access violation at address 005BA2DF in module 'PtokaX.exe'. Read of address 02AA4000

Call stack:
:005BA2DF [PtokaX.exe]
:0046E008 [PtokaX.exe] classUsers::UserSetLastPM (colUsers.cpp, line 2215)
:77F5C498 [USER32.dll]
:77F5CF8D [USER32.dll]
:77F6D01A [USER32.dll]
:005537EB [PtokaX.exe]
:004C9FB0 [PtokaX.exe] cDcCommands::To (DcCommands.cpp, line 3638)
:77371D5D [COMCTL32.DLL]
:7736FDE8 [COMCTL32.DLL]
:77371B56 [COMCTL32.DLL]
:77371BC0 [COMCTL32.DLL]
:77371BC8 [COMCTL32.DLL]
:77F54E9A [USER32.dll]
:77371E45 [COMCTL32.DLL]
:7C9313E4 [ntdll.dll]
:719C3DDF [MSWSOCK.dll]
:719B46D8 [MSWSOCK.dll]
:719B46FD [MSWSOCK.dll]
:7C826B9C [kernel32.dll]
:77F5C43A [USER32.dll]
:77F5C4C8 [USER32.dll]
:004B77E7 [PtokaX.exe] cDcCommands::PreProcessData (DcCommands.cpp, line 585)
:7C942816 [ntdll.dll]
:7C93FF8A [ntdll.dll]
:7C93F9DD [ntdll.dll]
:7736F3E4 [COMCTL32.DLL]
:773705A9 [COMCTL32.DLL]
:7C93F9DD [ntdll.dll]
:7C944260 [ntdll.dll]
:7C944298 [ntdll.dll]
:77F5C4C8 [USER32.dll]
:77F5C43A [USER32.dll]
:77F5C4C8 [USER32.dll]
:77F5C498 [USER32.dll]
:77F55563 [USER32.dll]
:7C9415DC [ntdll.dll]
:7C9415E1 [ntdll.dll]
:71A817FC [WS2HELP.dll]
:719B14C9 [MSWSOCK.dll]
:719C58C7 [MSWSOCK.dll]
Recursive call (2 times):
:719B199F [MSWSOCK.dll]
:71A92679 [WS2_32.dll]
:0046965B [PtokaX.exe] classUsers::UserProcessLines (colUsers.cpp, line 1612)
:00469072 [PtokaX.exe] classUsers::UserDoRecv (colUsers.cpp, line 1554)
:00469556 [PtokaX.exe] classUsers::UserDoRecv (colUsers.cpp, line 1584)
:00522CFD [PtokaX.exe]
:0056F75D [PtokaX.exe]
:0058F013 [PtokaX.exe]
:0058F02A [PtokaX.exe]
:0052BFD6 [PtokaX.exe]
:77F5C3B7 [USER32.dll]
:77F5C4C8 [USER32.dll]
:77F5C498 [USER32.dll]
:77F5C43A [USER32.dll]
:77F5C4C8 [USER32.dll]
:77F5C498 [USER32.dll]
:77F5CF8D [USER32.dll]
:77F6D01A [USER32.dll]
:005AA3E4 [PtokaX.exe]
:00485F9B [PtokaX.exe] theLoop::ReceiveLoop (serviceLoop.cpp, line 325)
:0052BFD6 [PtokaX.exe]
:77F5C3B7 [USER32.dll]
:77F5C4C8 [USER32.dll]
:77F5C498 [USER32.dll]
:77F5C43A [USER32.dll]
:77F5C4C8 [USER32.dll]
:77F5C498 [USER32.dll]
:77F5CF8D [USER32.dll]
:77F6D01A [USER32.dll]
:005AA3E4 [PtokaX.exe]
:00488658 [PtokaX.exe] theLoop::SendLoop (serviceLoop.cpp, line 807)
:00238BBE [PXLUA.DLL] luaD_pcall (ldo.c, line 461)
:002314C9 [PXLUA.DLL] lua_call (lapi.c, line 781)
:00231557 [PXLUA.DLL] lua_pcall (lapi.c, line 817)
:77F5CFB4 [USER32.dll]
:00581F8C [PtokaX.exe]
:77F5D01B [USER32.dll]
:00581F6A [PtokaX.exe]
:00581FC6 [PtokaX.exe]
:004859D8 [PtokaX.exe] theLoop::FOnTimer (serviceLoop.cpp, line 227)
:0058201E [PtokaX.exe]
:00581F04 [PtokaX.exe]
:0052BFD6 [PtokaX.exe]
:77F5C3B7 [USER32.dll]
:77F5C484 [USER32.dll]
:77F5C43A [USER32.dll]
:77F5C73C [USER32.dll]
:0052EA5F [PtokaX.exe]
:0052EBF3 [PtokaX.exe]
:77F4E406 [USER32.dll]
:0057EC38 [PtokaX.exe]
:0057EC6F [PtokaX.exe]
:0057EE8F [PtokaX.exe]
:0057EED2 [PtokaX.exe]
:00401C32 [PtokaX.exe] WinMain (PtokaX.cpp, line 62)
:005C66A9 [PtokaX.exe]
:005C666B [PtokaX.exe]
:00400000 [PtokaX.exe]
:7C8123E5 [kernel32.dll]

Modules:
$00400000 (00400000,00001000,001E0000) C:\DC2HUB\HUB\Hub 0.3.6.0\PtokaX.exe
$77F40000 (77F40000,00001000,00060E00) C:\WINDOWS\system32\USER32.dll
$77360000 (77360000,00001000,00090200) C:\WINDOWS\WinSxS\X86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.3790.2778_x-ww_A8F04F11\COMCTL32.DLL
$7C910000 (7C910000,00001000,00086800) C:\WINDOWS\system32\ntdll.dll
$719B0000 (719B0000,00001000,00037A00) C:\WINDOWS\system32\MSWSOCK.dll
$7C800000 (7C800000,00001000,00089E00) C:\WINDOWS\system32\kernel32.dll
$71A80000 (71A80000,00001000,00003E00) C:\WINDOWS\system32\WS2HELP.dll
$71A90000 (71A90000,00001000,00012600) C:\WINDOWS\system32\WS2_32.dll
$00220000 (00400000,00001000,0002B000) C:\DC2HUB\HUB\Hub 0.3.6.0\PXLUA.DLL

Main Thread ID = 000002EC, Current Thread ID = 000002EC
Registers:
EAX = 01FEF790  CS = 001B  EIP = 005BA2DF  Flags = 00010202
EBX = 01B5ABC4  SS = 0023  ESP = 0012F434    EBP = 0012F43C
ECX = 00000002  DS = 0023  ESI = 02AA3FFF    FS  = 003B
EDX = 000001E5  ES = 0023  EDI = 01FEF96C    GS  = 0000
Code at CS:EIP
F3 A5 8B CA 83 E1 03 F3 A4 5F 5E 5D C3 55 8B EC
Stack:
0012FE18 0058200C 0012F4EC 0046E008 01FEF790
00000000 7C8123E5 00542C05 0C71C00C 005DBF0B
011D60C4 011D2B0B 00000000 044F88BC 7C8123E5
FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF 00000001

Additional info:
Application Title : PtokaX DC Hub 0.3.6.0 Lua 5.1.2
Major : 5
Minor : 2
Build : 3790
SP : 1
Type : 3
iJoins: 2354691, iParts: 2353832, iLogged: 853
NicklistLen : 8615
OplistLen   : 52
MyInfosLen  : 0
MyInfosTagLen  : 73613
Title: Re: Error RegisteredUsers.xml
Post by: PPK on 27 June, 2007, 16:15:22
Crash is in same pm deflood, it is not in any way related to Registered Users.

//EDIT
Found and fixed, temporary fix before fixed version will be released is disabling same pm deflood.
Title: Re: Error RegisteredUsers.xml
Post by: nikita800 on 27 June, 2007, 22:29:31
Crash is in same pm deflood, it is not in any way related to Registered Users.
Why then if I delete file RegisteredUsers.xml the hub is started if I do not delete the hub is not started (hangs at start)?
Quote
Found and fixed, temporary fix before fixed version will be released is disabling same pm deflood
I and do not understand why there was a lag of a hub. It is too much PM messages?  ???

 Still I suggest to not let out because of one problem the new version (new release), and to lay out on a site old archive  (to replace with the new version with the corrected mistakes).  ;D

You will answer me in this theme? http://forum.ptokax.org/index.php?topic=7149.0
Title: Re: Error RegisteredUsers.xml
Post by: PPK on 28 June, 2007, 01:33:36
Why then if I delete file RegisteredUsers.xml the hub is started if I do not delete the hub is not started (hangs at start)?
Are you sure that it hangs ? Load too much registered users maybe take some time, try wait few minutes ;)
Title: Re: Error RegisteredUsers.xml
Post by: nikita800 on 28 June, 2007, 02:56:27
Are you sure that it hangs ? Load too much registered users maybe take some time, try wait few minutes ;)
Has checked up. Yes, it is really loaded very long (3 minutes), before such was not, the hub was loaded quickly. Has noticed still that with a database on users, the hub uses in 3 times of more memory. Without RegisteredUsers.xml all only 1400Kb
Title: Re: Error RegisteredUsers.xml
Post by: CrazyGuy on 28 June, 2007, 13:09:26
Has checked up. Yes, it is really loaded very long (3 minutes), before such was not, the hub was loaded quickly. Has noticed still that with a database on users, the hub uses in 3 times of more memory. Without RegisteredUsers.xml all only 1400Kb

You must have a shitload of registered users  :o
We (me, Snooze and Psycho_Chihuahua) done a test yesterday concerning RegisteredUsers.xml
10,000 accounts were created, and the file size was about 1200 KB, so less than your 1400.
Starting the soft took about a minute and a half.
We couldn't however, find any reason for the hub to not start, not even after manually corrupting the file in several ways
Title: Re: Error RegisteredUsers.xml
Post by: PPK on 29 June, 2007, 00:55:45
Yes, it is really loaded very long (3 minutes), before such was not, the hub was loaded quickly. Has noticed still that with a database on users, the hub uses in 3 times of more memory.
I don't know what you expecting when you trying to register every user on Direct Connect. Yes it take time to load too much registered users, yes it is use memory for them. Yes is possible to load them faster, but it will use more memory for them.
Title: Re: Error RegisteredUsers.xml
Post by: bastya_elvtars on 29 June, 2007, 01:13:57
I think you should use some type of usercleaner.
OT: Why aren't PtokaX config files Lua tables? :)
Title: Re: Error RegisteredUsers.xml
Post by: nikita800 on 30 June, 2007, 04:40:25
CrazyGuy: Can give me such base with 10000 users, I shall test at myself.
Also what you understand as expression " shitload of registered users "? Yes, some users are registered not one and at all two times. The majority of registration records are not used any more.
Title: Re: Error RegisteredUsers.xml
Post by: CrazyGuy on 30 June, 2007, 14:31:11
I think you are better off cleaning up some unused accounts  8)
Like PPK said, it will have a positive effect on hubs reaction time and memory usage.
Title: Re: Error RegisteredUsers.xml
Post by: nikita800 on 01 July, 2007, 05:56:58
How to delete not in the use registration records? What script is necessary to be utillized? Does can divided such script?
Title: Re: Error RegisteredUsers.xml
Post by: bastya_elvtars on 12 July, 2007, 04:25:26
You should search for regcleaner or usercleaner.
Fixed. Locking.