PtokaX forum

PtokaX => Bugs => Topic started by: eagle00789 on 22 March, 2008, 01:47:56

Title: DDOS protection is broken in 0.4.0.0c
Post by: eagle00789 on 22 March, 2008, 01:47:56
When setting the DDos protection to OFF and save the settings, it is saved. when you close ptokax and restart ptokax, the setting is back to ON.i have posted a videoproof of this bug: YouTube (http://www.youtube.com/watch?v=NGo0lypc4yM)
Title: Re: DDOS protection is broken in 0.4.0.0c
Post by: PPK on 22 March, 2008, 02:14:38
That is not bug, it is not saved. This change was forced by stupid hub owner of public PtokaX hub who disable that and team elite used his users to attack me.
Title: Re: DDOS protection is broken in 0.4.0.0c
Post by: eagle00789 on 22 March, 2008, 02:15:41
so how to fix this, because this setting is enabled, i can't connect to my own hub anymore.
[edit] i run the server on the same machine as the client. connecting to the server-address doesn't work for me [/edit]
Title: Re: DDOS protection is broken in 0.4.0.0c
Post by: eagle00789 on 22 March, 2008, 02:27:38
There are a number of options for you.
I run multiple hubs and clients on the same box, I can connect
from any to any using LAN or WAN addresses
  • Configure your connection properly [if loop back allowed
  • Upgrade your router [if loop back is not allowed
  • Disable the check IP in commands profile permission
check ip is already disabled for my userprofile. this worked before. but since this new option, i'm not allowed anymore. (if i disable this setting, i have to exit the hub, as ptokax runs as a service here)
how to configure my connection to allow loopback. my router and modem doesn't support loopback and upgrade is not possible as they both run the latetst versions of the software
Title: Re: DDOS protection is broken in 0.4.0.0c
Post by: PPK on 22 March, 2008, 03:04:14
Checked and enabling "Don't check IP in DC commands" for profile working for me ::)
Title: Re: DDOS protection is broken in 0.4.0.0c
Post by: eagle00789 on 23 March, 2008, 23:04:47
that is already on for me mate.