PtokaX forum

Development Section => Extensions for PXLua => Topic started by: PPK on 08 September, 2011, 00:47:08

Title: LuaFileSystem 1.5.0
Post by: PPK on 08 September, 2011, 00:47:08
New version for PtokaX 0.4.1.2 build 240 and higher (with Lua 5.1.4 only).

Homepage: http://keplerproject.github.com/luafilesystem/

Binary: http://www.PtokaX.org/files/Libs-240/LuaFileSystem-1.5.0.7z
Binary x64: http://www.PtokaX.org/files/Libs-240/LuaFileSystem-1.5.0-x64.7z

Source: http://www.PtokaX.org/files/Libs-240/LuaFileSystem-1.5.0-src.7z (original source with project files for Visual Studio 2010)

Initializing:
Code: [Select]
require "lfs"

This will register global lfs, more is in docs 8)
Title: Re: LuaFileSystem 1.5.0
Post by: PPK on 01 April, 2012, 10:27:45
New version for PtokaX 0.4.2.0 build 376 and higher.

Binary: http://www.PtokaX.org/files/Libs-376/LuaFileSystem-1.5.0.7z
Binary x64: http://www.PtokaX.org/files/Libs-376/LuaFileSystem-1.5.0-x64.7z
Source: http://www.PtokaX.org/files/Libs-376/LuaFileSystem-1.5.0-src.tar.gz

This lib is compatible with PXLua 5.1.5, 5.2.0 and 5.2.1 ;)

Update 8/May/2012:
Title: Re: LuaFileSystem 1.5.0
Post by: bastya_elvtars on 07 April, 2012, 13:25:23
Thank you very much.