PtokaX forum

PtokaX => Bugs => Topic started by: bastya_elvtars on 15 September, 2018, 22:41:28

Title: (rather an annoyance) Default directories in config/daemon/interactive
Post by: bastya_elvtars on 15 September, 2018, 22:41:28
When you invoke Ptokax with the -m switch it defaults to ~/PtokaX -- and does the same when you run the bot in interactive (that is, non-daemon) mode. However, if you start PtokaX with -d it seeks for config in ~/.PtokaX instead (one dot difference). I understand this can be overridden with the -c switch but took a while to figure it out. :D
Title: Re: (rather an annoyance) Default directories in config/daemon/interactive
Post by: PPK on 15 September, 2018, 23:51:43
This is little complicated. It defaults to current directory. But for daemon full path must be specified and if i remember correctly daemon have nothing like current directory so it gets current home directory of actual user and adds /.PtokaX
Title: Re: (rather an annoyance) Default directories in config/daemon/interactive
Post by: bastya_elvtars on 16 September, 2018, 13:46:33
Yeah, I was quite sure this wasn't a bug. Thanks for the clarification, will keep this in mind.
Title: rather an annoyance Default directories in config/daemon/interactive
Post by: Kellynem on 07 December, 2018, 05:08:58
Hey,

Um ok then, can that change? Or add an option to include the default filters?

Thanks,
 Will