Author Topic: "Unknown user agent, bye" message, when using dc++ socks5 feature  (Read 2814 times)

0 Members and 1 Guest are viewing this topic.

Offline junkie

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
-- 0.26 2003-07-15 --

* M:5 in the <++ tag means socks5 mode (this should have worked since 0.20...)

seems like ptokax isnt recognizing that "M:5"

PtokaX forum


Offline [NL]trucker

  • Lord
  • ***
  • Posts: 470
  • Karma: +2/-0
(No subject)
« Reply #1 on: 20 January, 2004, 21:39:55 »
there is allready a script out who prevents users with a sock5 connection to enter your hub.


just search for it.
Owner of FunnyHub
 
Funyhub.no-ip.info
       Forum Master of


Offline junkie

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
(No subject)
« Reply #2 on: 21 January, 2004, 02:07:25 »
i dont need to prevent them, i need, that ptokax ALLOWS entering through socks5. read the subject of thread ;)
Ptoka isnt recognizing that tag and disconnects users with that, saying "Unknown user agent, bye"

Offline plop

  • Forum God
  • ****
  • Posts: 2 464
  • Karma: +37/-0
(No subject)
« Reply #3 on: 21 January, 2004, 03:22:37 »
Quote
Originally posted by junkie
i dont need to prevent them, i need, that ptokax ALLOWS entering through socks5. read the subject of thread ;)
Ptoka isnt recognizing that tag and disconnects users with that, saying "Unknown user agent, bye"
well preventing them is only posible by scripts if they can enter.
this can be caused by 2 things, or you have some settings wrong or it's because trucker runs the beta which supports it.

plop
http://www.plop.nl lua scripts/howto\'s.
http://www.thegoldenangel.net
http://www.vikingshub.com
http://www.lua.org

>>----> he who fights hatred with hatred, drives the spreading of hatred <----<<

Offline astralqw

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
(No subject)
« Reply #4 on: 21 January, 2004, 23:40:54 »
hiya,

i just came by to post the exact same bug report as the initial poster.

When using DC++ in socks5 mode (because of a firewall...) the hub software will deny any connection attempt stating "cannot identify user agent" or something like that.

This IS (and that IS the reason trust me)  because even the most recent version of the PtokaX hub software does not understand the M:5 tag that gets send on initial connect.

This has not been an issue in the past because older DC++ clients (older than v0.260) incorrectly reported M:P when using socks5 mode so no problem there.

But in all the newer versions of DC++ this bug has been fixed. So M:5 is sent now!

Shouldnt be much of a problem to fix that in the hub software, too. I think most socks users would really appreciate being able to use direct connect again. :)

bye and keep up the good work
                    astral

Offline stinger

  • Junior Member
  • **
  • Posts: 10
  • Karma: +0/-0
(No subject)
« Reply #5 on: 05 September, 2004, 22:19:18 »
hiya...

hmm..  socks because of using firewall.. well not me.. i run active.... from behind a firewall.. and never had probs with it :D

Regards

Stinger

Offline plop

  • Forum God
  • ****
  • Posts: 2 464
  • Karma: +37/-0
(No subject)
« Reply #6 on: 05 September, 2004, 23:42:59 »
i'm running in active mode from behind a firewall and 2 routers.
just tryed it and ptokax 0.3.3.0 15.18 supports sock5 fine, alltho i couldn't test it fully as i don't have (or wanne have) a socks5 proxy.

it might be the proxy server which doesn't allow dc++ as it might be a unknown user agent for that.

plop
http://www.plop.nl lua scripts/howto\'s.
http://www.thegoldenangel.net
http://www.vikingshub.com
http://www.lua.org

>>----> he who fights hatred with hatred, drives the spreading of hatred <----<<

PtokaX forum

(No subject)
« Reply #6 on: 05 September, 2004, 23:42:59 »