Author Topic: PtokaX 0.3.3.0 build 16.07 released...  (Read 7166 times)

0 Members and 1 Guest are viewing this topic.

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 480
  • Karma: +209/-22
  • PtokaX developer
PtokaX 0.3.3.0 build 16.07 released...
« on: 27 March, 2005, 19:28:00 »
Please backup all config files from PtokaX folder before upgrade !

Changelog:
Quote
Added: Up/Down for script to change order for scripts run (request by plop).
Added: frmHuh:GetOnlineRegUsers() returning table with online registed users (request by Optimus).
Added: Up/Down for profiles, to changes profile order from highest to lowest.
Added: bConnected to lua for user object (request by Skrollster).
Added: GetTimer() and GetTimerInterval to lua (request by plop).
Added: GetTempBannedItemTime(IP) to lua (request by NightLitch).
Added: Possibility to set multiple hub commands prefix.
Fixed: Missing redirect message on lua redirect (thx Optimus for report).
Fixed: Problems with User Connected/Disconnected or Op Connected/Disconnected in some states (thx UwV for report).
Fixed: Saving of getnicklist deflood action (thx HW1 for report).
Fixed: Tab order for TAB gui elements switching (thx Herodes for report).
Fixed: NewUserConnected and OpConnected, if return 1 next scripts not proces it... same as in arrivals (thx NightLitch for report).
Fixed: Not saving few deflood settings (thx Jorgo for report).
Fixed: !op hub command working only first time bug (thx Meka Meka for report).
Fixed: Missing getnicklist lua arrival for clients supporting QuickList (thx The_Fox for report).
Fixed: Bugs in SetOpChat and SetHubBot (thx Skrollster for report).
Fixed: More Gui fixes (thx Skrollster for report).
Fixed: Few small memory leaks...
Fixed: Small bug in QuickList support cause disconnect if client send $GetNickList before $MyINFO (thx Carraya for report).
Fixed: Case-Sensitivity in reserved nicks bug.
Changed: User is no more disconnected if try to kick or redirect and is not allowed to do.
Changed: Tables returned by GetOnlineUsers, GetUsersByProfile and GetProfiles no more contains 0 element (thx Skrollster for report).
Changed: User disconnect for better sending of remaining data.
Changed: Lua scripts settings save/load, now is saved in .xml file instead of ini and script order is saved anc corectly loaded.
Changed: frmHub:GetMinShare() now return minshare in bytes ! (request by Skrollster).
Changed: Hub Bot and OpChat have now checkbox for enabling/disabling enabled on hub run.
Changed: Profiles saving, now is saved in .xml file. Automatic convertion from old .dat included.
Changed: Rest of .dat files converted to .xml files. Automatic conversion from old files included.
Changed: Port setting, primary port is needed for hub run (1 port), secondary ports (ex. 4861;8579;12589 = 3 ports) are optional.
Changed: Mass Message sent from hub GUI is now send from hub bot if is enabled.
Removed: Old and not working pinger detection by IP for hublist pinger.
Removed: Check if banitem already exist on permban loading, banlist is too slow for this (thx Motivations for report).
Updated: Some badwith optimizations...

Download from PtokaX homepage :]
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

PtokaX 0.3.3.0 build 16.07 released...
« on: 27 March, 2005, 19:28:00 »

Offline jiten

  • Scripter
  • Forum Legend
  • ******
  • Posts: 1 577
  • Karma: +71/-5
(No subject)
« Reply #1 on: 27 March, 2005, 20:15:12 »
Keep it coming  :]
Btw, great job PPK.

Offline Skrollster

  • Lord
  • ***
  • Posts: 293
  • Karma: +3/-0
(No subject)
« Reply #2 on: 27 March, 2005, 20:54:04 »
PPK, and ptokax keeps amaze me...

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 480
  • Karma: +209/-22
  • PtokaX developer
(No subject)
« Reply #3 on: 27 March, 2005, 20:54:55 »
Files removed  :(
Found problem with loading xml files contains special chars like ?  X(

If anyone know how to load this files using tinyxml, please help me...
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline ??????Hawk??????

  • Emperor
  • **
  • Posts: 1 044
  • Karma: +12/-2
    • Leeds Laptop Repairs
(No subject)
« Reply #4 on: 27 March, 2005, 21:11:12 »
hi m8  ..  
anychance of  Ditching the  XML  and going back to the normal  registeredusers.dat..

????

i was also having problems with   iShareSize  having a nil Value


« Last Edit: 27 March, 2005, 21:13:09 by ??????Hawk?????? »

Offline Pothead

  • Lord
  • ***
  • Posts: 455
  • Karma: +25/-4
(No subject)
« Reply #5 on: 27 March, 2005, 21:33:04 »
Maybe convert these characters to their Character code ?

Anna

  • Guest
(No subject)
« Reply #6 on: 27 March, 2005, 21:41:12 »
When looking at other xml files (favs file from my dc client) it starts with:


taking a look elsewhere also gives this as possible solution:


the encoding stuff should allow you to use all necessary charachters if I'm not all misstaken...
« Last Edit: 27 March, 2005, 21:44:37 by Anna »

Offline Psycho_Chihuahua

  • Systemspecialist IT
  • Emperor
  • **
  • Posts: 1 054
  • Karma: +112/-1
  • I am wherever i want to be
    • PtokaX Luaboard
(No subject)
« Reply #7 on: 27 March, 2005, 21:53:28 »
Well i got 16.07 running at the moment and also have Usernames containing ?,? and ? (german keyboards). Hubs running fine with no problems....
Ok i still have the "old" dat files in the root folder, but hey - it's up and running  :D

And i also took a look at the Registeredusers.xml and the ?,? and ?'s are all in the right places ^^
« Last Edit: 27 March, 2005, 21:53:44 by Psycho_Chihuahua »
PtokaxWiki ?PtokaX Mirror + latest Libs

01100001011011000111001101101111001000000110101101101110011011110111011101101110001000000110000101110011001000000101010001101111011010110110111101101100011011110111001101101000

Offline Jorgo

  • Double Ace
  • *
  • Posts: 103
  • Karma: +6/-6
(No subject)
« Reply #8 on: 27 March, 2005, 22:00:32 »
Please always use UTF-8 encoding in xml, webserver templates, etc. - this is the only way to achieve compatibility in all languages imho.

Offline Grizzly

  • Junior Member
  • **
  • Posts: 24
  • Karma: +0/-0
hi folks
« Reply #9 on: 27 March, 2005, 22:13:00 »
hi can someone point me to the download please

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 480
  • Karma: +209/-22
  • PtokaX developer
(No subject)
« Reply #10 on: 27 March, 2005, 22:13:06 »
Quote
Originally posted by ??????Hawk??????
anychance of  Ditching the  XML  and going back to the normal  registeredusers.dat..
No chance.
Quote
Originally posted by ??????Hawk??????
i was also having problems with iShareSize  having a nil Value
I check source and PtokaX never return nil for iShareSize  :rolleyes:
Quote
Originally posted by Anna
taking a look elsewhere also gives this as possible solution:

Yes i found it, missing encoding cause all problems :(
Quote
Originally posted by Psycho_Chihuahua
And i also took a look at the Registeredusers.xml and the ?,? and ?'s are all in the right places ^^
Yes save working without problems, but load of file fail X(
Quote
Originally posted by Jorgo
Please always use UTF-8 encoding in xml, webserver templates, etc. - this is the only way to achieve compatibility in all languages imho.
PtokaX not have UTF-8 support...
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline ruler

  • Triple Ace
  • **
  • Posts: 179
  • Karma: +7/-2
    • DCHubAd
(No subject)
« Reply #11 on: 27 March, 2005, 22:46:57 »
i godda take my hat off to you guys, what a great job !!!
ive never seen PtokaX running so well.
its nicely cleaned up and its good to know that most of the patches covering patches have been removed and replaced with new code. it was a bit like putting a bandage over another bandage and another over that  :D
great work guys

btw >>>  http://www.ptokax.org/   needs updating, its still showing 16.06  :D

regards
« Last Edit: 27 March, 2005, 22:52:25 by ruler »

Offline titan4

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
(No subject)
« Reply #12 on: 27 March, 2005, 22:53:27 »
What about saving language-specific characters as html entities.

PPK>Ty uz to nejak vyresis  :D

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 480
  • Karma: +209/-22
  • PtokaX developer
PtokaX 0.3.3.0 build 16.08 released...
« Reply #13 on: 27 March, 2005, 23:03:41 »
Fixed version released...

Changelog:
Quote
Fixed: Missing encoding in .xml files causing problem with loading files with special chars.
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline Psycho_Chihuahua

  • Systemspecialist IT
  • Emperor
  • **
  • Posts: 1 054
  • Karma: +112/-1
  • I am wherever i want to be
    • PtokaX Luaboard
(No subject)
« Reply #14 on: 27 March, 2005, 23:08:54 »
well in a lot of webcoding forums where they also use XML they recommend the use of this
Code: [Select]
encoding="ISO-8859-1"maybe that could help this problem in ptokax
PtokaxWiki ?PtokaX Mirror + latest Libs

01100001011011000111001101101111001000000110101101101110011011110111011101101110001000000110000101110011001000000101010001101111011010110110111101101100011011110111001101101000

Offline blackwings

  • Scripter
  • King
  • ******
  • Posts: 986
  • Karma: +12/-8
(No subject)
« Reply #15 on: 28 March, 2005, 01:06:49 »
Quote
Changed: Profiles saving, now is saved in .xml file. Automatic convertion from old .dat included.
how is the conversion made? do I just put my .dat files as usuall in the main directory and ptokax will convert them automaticlly to the .xml files in the cfg folder?
« Last Edit: 28 March, 2005, 01:10:26 by blackwings »


Offline ??????Hawk??????

  • Emperor
  • **
  • Posts: 1 044
  • Karma: +12/-2
    • Leeds Laptop Repairs
(No subject)
« Reply #16 on: 28 March, 2005, 01:37:20 »
hi  


just close hub, unzip  the new  ptokax files to your folder over writing the old ones and run your hub.

makin sure you have updated any scripts that need it first


??????Hawk??????
« Last Edit: 28 March, 2005, 01:37:46 by ??????Hawk?????? »

Offline jiten

  • Scripter
  • Forum Legend
  • ******
  • Posts: 1 577
  • Karma: +71/-5
(No subject)
« Reply #17 on: 28 March, 2005, 11:12:42 »
Yikes, new version in one day... cool :D
Well, the PtokaX site needs updating, but, u guys can get it if u copy the link of, let's say PtokaX 0.3.3.0 build 16.06 for Windows XP/2K/NT that is:

Code: [Select]
http://www.ptokax.org/download/files/0.3.3.0.b16.06.nt.rls.zip

and then just replace the "06" with "08".

That will do it.

Offline Cid

  • Member
  • ***
  • Posts: 38
  • Karma: +0/-0
(No subject)
« Reply #18 on: 28 March, 2005, 11:55:43 »
or press the "reload" button in your browser. or turn the cache of your browser off so that it reloads the sites everytime you visit them cuz its your browser that needs to update the site and not the site that needs updating ;)

Offline blackwings

  • Scripter
  • King
  • ******
  • Posts: 986
  • Karma: +12/-8
(No subject)
« Reply #19 on: 28 March, 2005, 19:55:43 »
with the new xml instead of .dat, is the "profile" bug fixed?


Offline sensi

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
(No subject)
« Reply #20 on: 28 March, 2005, 20:13:32 »
hi

yes a bug on the level of profiles reg and operator when one to use is recorded it is in profiles Op under PtokaX DC Hub 0.3.3.0 build 16.08.

????????????????????
MyHub : HipHopClub Fr & Us (hhcfrnice.sytes.net:415)
????????????????????
????????????????????
HipHopClub Fr & Us
Hub : PtokaX DC Hub 0.3.3.0 build 16.09 [debug]
Script : RoboCop v10.01c
         (hhcfrnice.sytes.net:415)
Web radio : Runing SAM2 V2.8.3
 listen here :)
????????????????????

PtokaX forum

(No subject)
« Reply #20 on: 28 March, 2005, 20:13:32 »