Author Topic: Post PtokaX DC Hub 0.3.3.0 build 17.07 bugs here!  (Read 4166 times)

0 Members and 1 Guest are viewing this topic.

Offline Madman

  • Scripter
  • Emperor
  • ******
  • Posts: 1 316
  • Karma: +75/-1
Post PtokaX DC Hub 0.3.3.0 build 17.07 bugs here!
« on: 17 May, 2005, 16:58:22 »
Quote
---------------------------2005-05-17 16:40:01---------------------------
Exception 'EAccessViolation' in module PtokaX.exe at 001B49C5
Access violation at address 005B59C5 in module 'PtokaX.exe'. Read of address 00000021

Call stack:
:005B59C5 [PtokaX.exe]
:77D38D14 [USER32.dll]
:780F121B [COMCTL32.DLL]
:780F1228 [COMCTL32.DLL]
:77D38CE0 [USER32.dll]
:780BBC56 [COMCTL32.DLL]
:77D38737 [USER32.dll]
:77D39153 [USER32.dll]
:77D3915E [USER32.dll]
Recursive call (2 times):
:77D38CE0 [USER32.dll]
:77D38D0B [USER32.dll]
:77D38D14 [USER32.dll]
:77D38CE0 [USER32.dll]
:780BBDC6 [COMCTL32.DLL]
:77D38737 [USER32.dll]
:77D39153 [USER32.dll]
:77D38654 [USER32.dll]
:77D38723 [USER32.dll]
:77D38CE0 [USER32.dll]
:77D38D0B [USER32.dll]
:77D38D14 [USER32.dll]
:77D38CE0 [USER32.dll]
:77D38D14 [USER32.dll]
:780BE58A [COMCTL32.DLL]
:77D3A7EB [USER32.dll]
:77D38654 [USER32.dll]
:77D38723 [USER32.dll]
:77D38765 [USER32.dll]
Recursive call (2 times):
:77D38737 [USER32.dll]
:77D39153 [USER32.dll]
Recursive call (2 times):
:77D3915E [USER32.dll]
:77F75DA3 [ntdll.dll]
:77D3A4D3 [USER32.dll]
:77D4D5A2 [USER32.dll]
:77D3AA95 [USER32.dll]
:005855E0 [PtokaX.exe]
:00544052 [PtokaX.exe]
:00582557 [PtokaX.exe]
:0051A382 [PtokaX.exe]
:77D38654 [USER32.dll]
:77D38723 [USER32.dll]
:77D38765 [USER32.dll]
Recursive call (2 times):
:77D38737 [USER32.dll]
:77D3A0EC [USER32.dll]
:00532A07 [PtokaX.exe]
:0053499E [PtokaX.exe]
:00532986 [PtokaX.exe]
:005854FC [PtokaX.exe]
:005B4EDB [PtokaX.exe]
:00437D0C [PtokaX.exe] THubCommands::DoCommand (HubCommands.cpp, line 1089)
:77F75DA3 [ntdll.dll]
:77D3A4D3 [USER32.dll]
:77D4D5A2 [USER32.dll]
:77D3AA95 [USER32.dll]
:005855E0 [PtokaX.exe]
:00544052 [PtokaX.exe]
:00582557 [PtokaX.exe]
:780BBC56 [COMCTL32.DLL]
:77D38737 [USER32.dll]
:77D39153 [USER32.dll]
Recursive call (2 times):
:77D3915E [USER32.dll]
:77D3B9AE [USER32.dll]
:77D3B9BE [USER32.dll]
:77D3AA95 [USER32.dll]
:005855E0 [PtokaX.exe]
:00544052 [PtokaX.exe]
:00582557 [PtokaX.exe]
:005854FC [PtokaX.exe]
:00510FFD [PtokaX.exe]
:005658C1 [PtokaX.exe]
:00585177 [PtokaX.exe]
:0058518E [PtokaX.exe]
:0051A382 [PtokaX.exe]
:77D38654 [USER32.dll]
:77D38723 [USER32.dll]
:77D38765 [USER32.dll]
Recursive call (2 times):
:77D38737 [USER32.dll]
:77D39153 [USER32.dll]
:005855E0 [PtokaX.exe]
:77D3915E [USER32.dll]
:77D3B9AE [USER32.dll]
:77D3B9BE [USER32.dll]
:77D38723 [USER32.dll]
:77F75DA3 [ntdll.dll]
:77D3A4D3 [USER32.dll]
:77D4D5A2 [USER32.dll]
:77D3AA95 [USER32.dll]
:005855E0 [PtokaX.exe]
:00544052 [PtokaX.exe]
:00582557 [PtokaX.exe]
:77E70622 [kernel32.dll]
Recursive call (2 times):
:77E7062A [kernel32.dll]
:780BC5C0 [COMCTL32.DLL]
:780EA677 [COMCTL32.DLL]
:77D38CE0 [USER32.dll]
:780BE620 [COMCTL32.DLL]
:77D38765 [USER32.dll]
:77D38654 [USER32.dll]
:77D38765 [USER32.dll]
:005854FC [PtokaX.exe]

Main Thread ID = 00001538, Current Thread ID = 00001538
Registers:
EAX = 7FFFFFFF  CS = 001B  EIP = 005B59C5  Flags = 00010206
EBX = 00542D73  SS = 0023  ESP = 0012E070    EBP = 0012E59C
ECX = 00000000  DS = 0023  ESI = 00612408    FS  = 0038
EDX = 00000021  ES = 0023  EDI = 00000020    GS  = 0000
Code at CS:EIP
80 3A 00 75 EE E9 C9 00 00 00 F7 C7 00 01 00 00
Stack:
0012FE48 00578170 00542DBC 4D3D2D3C 65536461
00000000 00000000 005854FC 00534005 01636E70
005FC90B 00000002 00000000 00000000 015E297C
005854FC FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF

Additional info:
Application Title : PtokaX DC Hub 0.3.3.0 build 17.07 [debug]
Major : 5
Minor : 1
Build : 2600
SP : 1
Type : 1
iJoins: 220, iParts: 215, iLogged: 5
NicklistLen : 67
OplistLen   : 57
MyInfosLen  : 0
MyInfosTagLen  : 642
QueueA Size : 94
QueueA Len : 0
QueueB Size   : 80
QueueB Len   : 0
PQueue Size  : 15
PQueue Len  : 0
HQueueA Size  : 36
HQueueA Len  : 0
HQueueB Size  : 38
HQueueB Len  : 0
OPQueueA Size  : 203
OPQueueA Len  : 0
OPQueueB Size  : 201
OPQueueB Len  : 0
InfoQueue Size  : 343
InfoQueue Len  : 0
OQ-QueueA Size  : 148
OQ-QueueA Len  : 0
OQ-QueueB Size  : 148
OQ-QueueB Len  : 0

happend when i tryed to restart a stoped script...
We suffer in silence, we lurk in the shadows, we kill in the night
Site currently down, ETA of returning online is 2099 ;p

PtokaX forum

Post PtokaX DC Hub 0.3.3.0 build 17.07 bugs here!
« on: 17 May, 2005, 16:58:22 »

Offline hutchenky

  • Member
  • ***
  • Posts: 45
  • Karma: +0/-0
(No subject)
« Reply #1 on: 17 May, 2005, 22:13:35 »
i had the same just a min ago but in 1705, so the 1707 is the same
so i have to wait till 1708.

cheers :hutch

Offline hutchenky

  • Member
  • ***
  • Posts: 45
  • Karma: +0/-0
(No subject)
« Reply #2 on: 17 May, 2005, 23:00:38 »
1707 doesn't work with rc 1001e,
Syntax logs/kick.log:7: unexpected symbol near `'this appears, is this with everyone the same?

Offline Pr?sten

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
(No subject)
« Reply #3 on: 17 May, 2005, 23:04:41 »
*moved from "Client Strong rc5 dont work whit 17.07"

orginal mesg:

Found a problem whit Ptokax 17.07

When you get a file lsit whit client strong rc5, you get disconnected directly.

anyone got any ideas?


/Pr?sten
dvdr / Mp3 hub--> pentagon.no-ip.info

Offline (NL)waarom

  • Member
  • ***
  • Posts: 40
  • Karma: +0/-0
1707 doesn't work with rc 1001e,
« Reply #4 on: 17 May, 2005, 23:05:38 »
Version: PtokaX DC Hub 0.3.3.0 build 17.07 [debug] built on May 15 2005 20:59:05
Uptime: 1 days, 12 hours, 25 minutes
Users (Max/Actual Peak (Max Peak)/Logged) : 700 / 592 (592) / 496
hmm running pt 17.07 whit robo 10.01e
works thust fine here

Offline Pr?sten

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
(No subject)
« Reply #5 on: 17 May, 2005, 23:06:09 »
Quote
Originally posted by Pr?sten
*moved from "Client Strong rc5 dont work whit 17.07"

orginal mesg:

Found a problem whit Ptokax 17.07

When you get a file lsit whit client strong rc5, you get disconnected directly.

anyone got any ideas?


/Pr?sten


Zitat:
--------------------------------------------------------------------------------
Originally posted by [NL]Pur
what steps did you take to come to this conclusion ?

--------------------------------------------------------------------------------



will paste this in "repport for ptokax 17.07"

i tried 4 different clients, and tryied them in different ptokax.. only in 17.07 and storng rc5 i got the problem
dvdr / Mp3 hub--> pentagon.no-ip.info

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 744
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
(No subject)
« Reply #6 on: 18 May, 2005, 00:36:17 »
Do you have a router? And, which part of the transfer is that triggers the disconnect? I am asking because only connection requests are forwarded by a hub, however this seems to be a bad IP problem.
Everything could have been anything else and it would have just as much meaning.

Offline uffetjur

  • Lord
  • ***
  • Posts: 289
  • Karma: +4/-0
(No subject)
« Reply #7 on: 18 May, 2005, 01:34:59 »
Did a test with strong connected to ptokax
--------------------------------0.3.3.0 build 17.07 15.May.2005----------------------------
Running witout any scripts
Looks as hes strong client sends a $getinfo direct after the filelist is downloaded, probably a bug in strong dc
hes got disconnected right after $getinfo is sent

-------------------------------------------------------------
with strong 1.00RC5
[01:18] Nick (xxx.xxx.xxx.xxx) > $ConnectToMe [User xx.xx.xx.xx:18648|
[01:18] Nick (xxx.xxx.xxx.xxx) > $GetINFO user Nick
[01:18] x User removed: Nick (Socket 440)


with fulDC6.64
[01:21] Nick (xxx.xxx.xxx.xxx) > $ConnectToMe [User xx.xx.xx.xx:13942|

with Strong 1.00RC5
[01:24] Nick (xxx.xxx.xxx.xxx) > $ConnectToMe [User xx.xx.xx.xx:18648|
[01:24] Nick (xxx.xxx.xxx.xxx) > $GetINFO user Nick
[01:24] x User removed: Nick (Socket 440)


As I can se this must be a client related bug

Nick (xxx.xxx.xxx.xxx) is connected as master in all 3 cases


Strange is, this error didnt occure with earlier versions of ptokax
« Last Edit: 18 May, 2005, 01:42:54 by uffetjur »
Somewhere in Cyberspace

Offline Pr?sten

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
(No subject)
« Reply #8 on: 18 May, 2005, 01:40:29 »
Oki, Bull.. THANKS!

Will tell the "Smurf" that, (the guy whit the problem)

My misstake that not looking that up first, befor asking, Sorry for that.

/Pr?sten
dvdr / Mp3 hub--> pentagon.no-ip.info

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 480
  • Karma: +209/-22
  • PtokaX developer
(No subject)
« Reply #9 on: 18 May, 2005, 06:25:56 »
Quote
Originally posted by madman
Quote
:00437D0C [PtokaX.exe] THubCommands::DoCommand (HubCommands.cpp, line 1089)
Fixed :]
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline Star

  • Double Ace
  • *
  • Posts: 100
  • Karma: +0/-0
(No subject)
« Reply #10 on: 18 May, 2005, 17:10:58 »
MOTD don't save om exit.
The same with HubDescription.

Sometimes it saves and sometimes it don't.

Thx Star

EDIT: Sorry. just started the wrong hub =) lol
Another bug. PtokaX don't minimize on start. Have it checked in windows shourtcut.
« Last Edit: 18 May, 2005, 17:15:56 by Star »

Offline Dessamator

  • Scripter
  • Emperor
  • ******
  • Posts: 1 262
  • Karma: +13/-9
(No subject)
« Reply #11 on: 23 May, 2005, 11:01:31 »
Code: [Select]
---------------------------5/23/2005 10:16:42 AM---------------------------
Exception 'EAccessViolation' in module PtokaX.exe at 001A022F
Access violation at address 005A122F in module 'PtokaX.exe'. Write of address 00F13C24

Call stack:
:005A122F [PtokaX.exe]
:0041F830 [PtokaX.exe] ThubForm::PxWndProc (frmHub.cpp, line 3306)
:00585177 [PtokaX.exe]
:0051A382 [PtokaX.exe]
:77D48734 [USER32.dll]
:77D48816 [USER32.dll]
:77D4B4C0 [USER32.dll]
:77D4B50C [USER32.dll]
:7C90EAE3 [ntdll.dll]
:77D4BE69 [USER32.dll]
:77D959A5 [USER32.dll]
:77D7CA8E [USER32.dll]
:77D48734 [USER32.dll]
:77D545E4 [USER32.dll]
:77D53FD9 [USER32.dll]
:77D484FC [USER32.dll]
:77D485A4 [USER32.dll]
:77D54204 [USER32.dll]
:77D48734 [USER32.dll]
:77D48816 [USER32.dll]
:77D4B89B [USER32.dll]
:77D54E28 [USER32.dll]
:77D4F00B [USER32.dll]
Recursive call (2 times):
:77D40000 [USER32.dll]
:77D561B3 [USER32.dll]
:77D6A92E [USER32.dll]
:77D40000 [USER32.dll]
:77D488D1 [USER32.dll]
:77D488DA [USER32.dll]
:774188A1 [COMCTL32.DLL]
:77420E9F [COMCTL32.DLL]
:77420599 [COMCTL32.DLL]
:77D484FC [USER32.dll]
:77D485A4 [USER32.dll]
:7C910833 [ntdll.dll]
:7C9037BF [ntdll.dll]
:7C90378B [ntdll.dll]
Recursive call (2 times):
:7C910732 [ntdll.dll]
:7C9106AB [ntdll.dll]
:7C9106EB [ntdll.dll]
:7C910732 [ntdll.dll]
:77D4882A [USER32.dll]
:7C910732 [ntdll.dll]
:7C9106AB [ntdll.dll]
:7C9106EB [ntdll.dll]
:7C910732 [ntdll.dll]
:7C9106AB [ntdll.dll]
:7C9106EB [ntdll.dll]
:77D6A294 [USER32.dll]
:7C9105C8 [ntdll.dll]
:7C910551 [ntdll.dll]
:7C91056D [ntdll.dll]
:77D95FBB [USER32.dll]
:77D96060 [USER32.dll]
:77D80577 [USER32.dll]
:77D8052F [USER32.dll]
:005BC283 [PtokaX.exe]
:77F643D0 [SHLWAPI.dll]
:005BDDCE [PtokaX.exe]
:005BD847 [PtokaX.exe]
:005BC3DE [PtokaX.exe]
:005BC3F5 [PtokaX.exe]
:005B1842 [PtokaX.exe]
:005B2358 [PtokaX.exe]
:005B18F6 [PtokaX.exe]
:005C0372 [PtokaX.exe]
:005C04CE [PtokaX.exe]
:005A4A99 [PtokaX.exe]
:005C04CE [PtokaX.exe]
:005C03DD [PtokaX.exe]
:005C06EA [PtokaX.exe]
:005C0C85 [PtokaX.exe]
:00400000 [PtokaX.exe]
:005BFC3E [PtokaX.exe]
:005BFE5E [PtokaX.exe]
:7C910895 [ntdll.dll]
Recursive call (2 times):
:00400000 [PtokaX.exe]
:7C912975 [ntdll.dll]
:00400000 [PtokaX.exe]
:7C9129B9 [ntdll.dll]
:00400000 [PtokaX.exe]
:7C910833 [ntdll.dll]
Recursive call (2 times):
:00400000 [PtokaX.exe]
:7C9129B9 [ntdll.dll]
:7C912C59 [ntdll.dll]
:00400000 [PtokaX.exe]
:7C912937 [ntdll.dll]
:7C912C99 [ntdll.dll]
:00400000 [PtokaX.exe]
:7C912CB7 [ntdll.dll]
:7C80A08E [kernel32.dll]
:00400000 [PtokaX.exe]
:7C80A0A5 [kernel32.dll]
:77D50CC4 [USER32.dll]
:00532A07 [PtokaX.exe]
:7C9037BF [ntdll.dll]
:7C90378B [ntdll.dll]
:7C937B48 [ntdll.dll]
:77D4885A [USER32.dll]
:77D4882A [USER32.dll]

Main Thread ID = 000014B0, Current Thread ID = 000014B0
Registers:
EAX = 00DE647C  CS = 001B  EIP = 005A122F  Flags = 00010283
EBX = 00DE647C  SS = 0023  ESP = 0012D6E8    EBP = 0012D6F8
ECX = 00E6FF94  DS = 0023  ESI = 003D0FD5    FS  = 003B
EDX = 0012D730  ES = 0023  EDI = 0012D7A8    GS  = 0000
Code at CS:EIP
00 04 1F 51 00 04 1E 51 00 68 2E 51 00 9C 2E 51
Stack:
00E6FF94 0041F830 0012D730 00DE647C 0012D728
00000000 00000000 77D4882A 00534005 00E713CC
005FC90B 00000002 00000000 00000000 00E71038
77D4882A FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF

Additional info:
Application Title : PtokaX DC Hub 0.3.3.0 build 17.07 [debug]
Major : 5
Minor : 1
Build : 2600
SP : 2
Type : 1
iJoins: 0, iParts: 0, iLogged: 0


thats a bug somebody had with ptokax 17.07, dunno if its fixed in the new one !!
Ignorance is Bliss.

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 744
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
(No subject)
« Reply #12 on: 24 May, 2005, 14:01:05 »
When you open a PX and copy a script with errors to the scripts folder afterwards, and then fix the errors, script stays disabled. Not that big deal but...
Everything could have been anything else and it would have just as much meaning.

PtokaX forum

(No subject)
« Reply #12 on: 24 May, 2005, 14:01:05 »