Author Topic: Which clients does Robocop support?  (Read 3328 times)

0 Members and 1 Guest are viewing this topic.

Offline Propaganda

  • Member
  • ***
  • Posts: 27
  • Karma: +1/-0
Which clients does Robocop support?
« on: 18 July, 2006, 21:41:43 »
Optimus,

I am planning a major upgrade of the hubsoftware I am using, jumping from 0.330 bld 15.25 using 9.0g to 0.3.5.1 using 10.022.

The only thing I am missing now is a allowed client list....which I used to ban certain clients from the hub, and also to set a minimum client version people should be using.

I noticed the minimum client list in the new robocop version, but it only mentions dc++, nmdc and valknut.
Are these the only clients allowed?
Or is it so that when I want to allow Strongdc++ or Fulldc++, I add them to the list using the clients name, and enter the minimum version for them allowed?

Or does it not work this way?

Or does Robocop work with all clients based on dc++?
And what about Apple clients....and other linux based clients?

Thanks for your effort on putting a new version together....

PtokaX forum

Which clients does Robocop support?
« on: 18 July, 2006, 21:41:43 »

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 745
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
Re: Which clients does Robocop support?
« Reply #1 on: 18 July, 2006, 22:13:49 »
Well, I guess (!) RC client supports are includen in an XML file that is bundled with the script. The MAC client and the other popular Linux client (linuxdcpp) do  send normal DC++ tags. As for StrongDC++ and other clients with crazy tags, well... it depends on that ClientTags.xml - again: just a guess!
Everything could have been anything else and it would have just as much meaning.

Offline Propaganda

  • Member
  • ***
  • Posts: 27
  • Karma: +1/-0
Re: Which clients does Robocop support?
« Reply #2 on: 18 July, 2006, 22:44:08 »
Thanks Bastya....but isn't the ClientTags.xml file part of Ptokax, and not Robocop.
I did find the file, and in it it does mention all types of clients.....
Does Robocop look into this file as well?? And if so do I use the "ClientName" as it appears in this xml file in the minimum version table of robocop, and next add a minimum version to it?

from the file:? ?

? ? <Client>
? ? ? ? <ClientTag>++</ClientTag>
? ? ? ? <ClientName>DC++</ClientName>
? ? </Client>
? ? <Client>
? ? ? ? <ClientTag>DCGUI</ClientTag>
? ? ? ? <ClientName>Valknut</ClientName>
? ? </Client>
etc.....

Another question which I thought of.....are clients from my banned clients list in the old robocop still denied after I switch, like stealth clients, reverse connect, ragnarok etc etc....

Thanks for the quick reply...
« Last Edit: 18 July, 2006, 22:48:37 by Propaganda »

Offline Optimus

  • Emperor
  • **
  • Posts: 1 474
  • Karma: +13/-1
Re: Which clients does Robocop support?
« Reply #3 on: 19 July, 2006, 10:12:40 »
yes ClientTags.xml file is linked to robocop. The tags/clients you use in ClientTags.xml file can be added to robocop GUI to set minversion.

yes you use the ClientName to add to GUI then enter minversion.

Offline ExtreeM

  • Forum Ace
  • *****
  • Posts: 83
  • Karma: +33/-6
Re: Which clients does Robocop support?
« Reply #4 on: 15 December, 2007, 05:09:10 »
let me see if i get this right? the client tags in ClientTags.xml is the clients thats allowed in the hub and it works with RC??

ex.

i want to add airdc++ to the hub

then i just apply this setup

    <Client>
        <ClientTag>AirDC++</ClientTag>
        <ClientName>AirDC++</ClientName>
    </Client>

is this right??

Offline CrazyGuy

  • Viking
  • ****
  • Posts: 506
  • Karma: +83/-20
    • ?????=-_The NightHawk_-=?????
Re: Which clients does Robocop support?
« Reply #5 on: 15 December, 2007, 15:13:49 »
yup

PtokaX forum

Re: Which clients does Robocop support?
« Reply #5 on: 15 December, 2007, 15:13:49 »