Author Topic: Conflict Problem with two scripts  (Read 2707 times)

0 Members and 1 Guest are viewing this topic.

Offline Stravides

  • Triple Ace
  • **
  • Posts: 171
  • Karma: +0/-0
Conflict Problem with two scripts
« on: 11 January, 2004, 08:56:52 »
I am using two bots on my hub, basically guardian and a trivia bot, the problem is that on the counter it gives the hubstats thats ok, but when a user uses a guardian command every now and again it spams every user playing trivia with the rules or help or other such :(   Any idea why this would be the case ?  I will soon start to lose users over this as I'm getting peeved with it so god knows how the users are feeling...  I am a newbie to this lua, and require help.  Many thanks all...

I do not wish to place reams of code here so I will add the links to the two scripts.. many thanks

Ammended Guardian Script
Ammended Trivia Script


Stravides




Stravides

RPGBooks-cymru.no-ip.org:(
Stravides
For RPG Books, Mp3 & Videos
We host trivia  and the ever failing Smeagolbot

PtokaX forum

Conflict Problem with two scripts
« on: 11 January, 2004, 08:56:52 »

Offline Stravides

  • Triple Ace
  • **
  • Posts: 171
  • Karma: +0/-0
(No subject)
« Reply #1 on: 11 January, 2004, 09:07:14 »
ignore last thread, just found new version, trying that out

stravides
Stravides
For RPG Books, Mp3 & Videos
We host trivia  and the ever failing Smeagolbot

Offline Stravides

  • Triple Ace
  • **
  • Posts: 171
  • Karma: +0/-0
Conflict Problem with two scripts strike 2 :)
« Reply #2 on: 11 January, 2004, 09:38:21 »
Ok used vanilla script here to see if was my ammendments..
Using Troubadors Guardian 0.7 and the
trivia script here

Ok run up trivia using !trivia this starts quiz as required, and questions on the fly :) Marvelous

Ok Type !rules you get a lovely set of rules from guardian Whoo hooo...

heres where the pap happens

in the trivia PM type !hint you then get the rules pm'd to every user :(

any help would be gratefully received..

dunno if there is a clear function to clear the !rules func from memory or something

Please help.... before I lose any more users

Many Many thanks in advance

Stravides
RPGBooks Cymru
RPGBooks-Cymru.no-ip.org



Stravides
Stravides
For RPG Books, Mp3 & Videos
We host trivia  and the ever failing Smeagolbot

Offline plop

  • Forum God
  • ****
  • Posts: 2 464
  • Karma: +37/-0
(No subject)
« Reply #3 on: 12 January, 2004, 00:09:07 »
have you also tryed using a newer version of guardian???
if it also happens on that other trivia bot i think you should ask troubadour about it in hiso wn tread.

plop
http://www.plop.nl lua scripts/howto\'s.
http://www.thegoldenangel.net
http://www.vikingshub.com
http://www.lua.org

>>----> he who fights hatred with hatred, drives the spreading of hatred <----<<

Offline Stravides

  • Triple Ace
  • **
  • Posts: 171
  • Karma: +0/-0
Thanks
« Reply #4 on: 12 January, 2004, 01:46:30 »
Yea I changed the guardian to .07, and it still goes crappy :(  

Just wondering if there is a requirement to flush the cache or anything ?

its happening all the time at the mo,  upsetting a lot of ppl
Stravides
For RPG Books, Mp3 & Videos
We host trivia  and the ever failing Smeagolbot

Offline plop

  • Forum God
  • ****
  • Posts: 2 464
  • Karma: +37/-0
(No subject)
« Reply #5 on: 12 January, 2004, 02:26:43 »
check here
he's on version 1.3 allready.
btw does it also happen if some1 says !hint in pm 2 some1 else?
sounds like a pm mix up on guardian/trivia in a weird way.

plop
http://www.plop.nl lua scripts/howto\'s.
http://www.thegoldenangel.net
http://www.vikingshub.com
http://www.lua.org

>>----> he who fights hatred with hatred, drives the spreading of hatred <----<<

Offline Stravides

  • Triple Ace
  • **
  • Posts: 171
  • Karma: +0/-0
eeeeeeeeek
« Reply #6 on: 12 January, 2004, 10:29:17 »
ok now loaded 1.3 of troubadors guardian...
Only difference now is that the bot does not PM everyone, its all in main chat :)

I run trivia, i do a !rules then into pm window and type !tbpart to leave trivia and guardian picks it up an displays the rules again :(

help would be gratefully received
Stravides
For RPG Books, Mp3 & Videos
We host trivia  and the ever failing Smeagolbot

Offline plop

  • Forum God
  • ****
  • Posts: 2 464
  • Karma: +37/-0
(No subject)
« Reply #7 on: 12 January, 2004, 11:14:07 »
i took a quick look and it's indeed a bug in guardian.
they don't check if it's actualy for there bot or not.
it's a bit messy in the script but tryed 2 make a quick fix you, i hope it works.
you can get it here.
it's just the main file.

plop
http://www.plop.nl lua scripts/howto\'s.
http://www.thegoldenangel.net
http://www.vikingshub.com
http://www.lua.org

>>----> he who fights hatred with hatred, drives the spreading of hatred <----<<

Offline [NL]trucker

  • Lord
  • ***
  • Posts: 470
  • Karma: +2/-0
(No subject)
« Reply #8 on: 12 January, 2004, 14:00:01 »
Stravides

first try out the fix from plop
and if the fix from plop doesnt work you always can change the prefix from one of the bots.

e.g from !help to ?help

i think that will work to.
Owner of FunnyHub
 
Funyhub.no-ip.info
       Forum Master of


PtokaX forum

(No subject)
« Reply #8 on: 12 January, 2004, 14:00:01 »