Lua 5.3/5.2/5.1 Scripts (for PtokaX 0.4.0.0 and newer) > Help with scripts

FreshStuff3 5.5 alpha 1 bug

(1/1)

carpat:
Hello!
I try to run FreshStuff3 5.5 alpha 1 on 0.5.0.2-Lua5.1.5-x64 on Win 7 and i get this error:
Syntax error loading module 'pxlfs' from file 'D:/0.5.0.2-Lua5.1.5-x64/scripts/freshstuff/lib/pxlfs.dll':
   %1 is not a valid Win32 application.
Please help!
10x!

kyyarutek:
I just successfully run FreshStuff 5.0.1 on Ptokax 5.0.0.2 Lua 5.1.5. You need to copy two files: lfs.dll & lfs.pdb from LuaFileSystem 1.6.2 Win32 (download from ptokax home). Paste these files in /scripts/freshstuff/libnew. Change their names to PXLFS.dll and PXLFS.pdb (replace).

Let me know, if FreshStuff3 5.5 run it well.

Greetings

carpat:
It works fine,10x for help,but it hasn't the add release function.. :(

bastya_elvtars:
Hello guys and sorry for not showing up lately.
First, there is a dedicated subforum for FreshStuff.
There is also a post on the 5.5 alpha1 release here. Indeed, those links are already dead as I have moved everything to BitBucket and did a few infrastructural changes to the codebase etc. I will make downloadable packages as soon as I get the time and do a new post on the future of the bot.
In a nutshell: the infrastructure is ready for coding and I have plans. But I cannot give you a release schedule due to hard working aka LIFE. However, 5.5 will have release approval system and asynchronous release additions, also there will be tweakable partial/full matching against existing releases. It is undecided whether I will convert the code to 5.2 first but there will be no parallel-maintained 5.1 and 5.2 releases. (If someone wants to do that, contributions are welcome!)
After 5.5 I intend to pick up a 'release early, release often'-model. Future versions of the bot are going to include cached database writing and RSS feed generator intended to work together with the built-in PtokaX web server.

Navigation

[0] Message Index

Go to full version