Author Topic: Server always saying <Enter - Hub name here>  (Read 3214 times)

0 Members and 1 Guest are viewing this topic.

Offline HtHNightwolf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Server always saying <Enter - Hub name here>
« on: 05 May, 2016, 04:19:20 »
Dear Community,

I have a bit of a problem with a PtokaX server that I just set up running on lubuntu 15.10. I use the newest version of PtokaX from the website.

Thing is, I am a Windows Admin and have my troubles with Linux. A lack of experiance. I never compiled anything before so this was alot reading HowTos for me ;)

My PtokaX is installed in /srv/PtokaX. I edited the Settings.pxt file in /srv/PtokaX/cfg/Settings.pxt and modified the line
#HubName = TestLAN

But whenever I connect to the Hub, If says <Enter - Hub name here> in the top line of the client's window.
I'd appreciate any tip what I am doing wrong.

PtokaX forum

Server always saying <Enter - Hub name here>
« on: 05 May, 2016, 04:19:20 »

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 478
  • Karma: +209/-22
  • PtokaX developer
Re: Server always saying <Enter - Hub name here>
« Reply #1 on: 05 May, 2016, 06:19:39 »
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline HtHNightwolf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Server always saying <Enter - Hub name here>
« Reply #2 on: 05 May, 2016, 15:55:43 »
Thanks mate, that looks promising. From all my 800 Google searches, why did I not find -m?  :boxed:

Offline HtHNightwolf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Server always saying <Enter - Hub name here>
« Reply #3 on: 05 May, 2016, 15:58:14 »
Nope, I completed the basic setup.
It asked for the hub name, I modified it but a client still reads "Enter - hub name here" in the window top.

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 478
  • Karma: +209/-22
  • PtokaX developer
Re: Server always saying <Enter - Hub name here>
« Reply #4 on: 05 May, 2016, 17:35:14 »
Then you provide to PtokaX wrong settings directory. Or PtokaX don't have permission to read or write to settings directory ...
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline HtHNightwolf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Server always saying <Enter - Hub name here>
« Reply #5 on: 05 May, 2016, 22:05:59 »
Thanks, I had this idea myself but the PC is in the car right now.
I will check it tomorrow if the settings file has rights to be edited.

Where can I set PtokaX the settings directory? I thought it uses the settings file in it's own cfg subfolder

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 478
  • Karma: +209/-22
  • PtokaX developer
Re: Server always saying <Enter - Hub name here>
« Reply #6 on: 14 May, 2016, 14:56:10 »
PtokaX use his root directory when is run as console application. When is run as daemon the use /home/current_user/.PtokaX directory.
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

Re: Server always saying <Enter - Hub name here>
« Reply #6 on: 14 May, 2016, 14:56:10 »