Recent posts
 

News:

29 December 2022 - PtokaX 0.5.3.0 (20th anniversary edition) released...
11 April 2017 - PtokaX 0.5.2.2 released...
8 April 2015 Anti child and anti pedo pr0n scripts are not allowed anymore on this board!
28 September 2015 - PtokaX 0.5.2.1 for Windows 10 IoT released...
3 September 2015 - PtokaX 0.5.2.1 released...
16 August 2015 - PtokaX 0.5.2.0 released...
1 August 2015 - Crowdfunding for ADC protocol support in PtokaX ended. Clearly nobody want ADC support...
30 June 2015 - PtokaX 0.5.1.0 released...
30 April 2015 Crowdfunding for ADC protocol support in PtokaX
26 April 2015 New support hub!
20 February 2015 - PtokaX 0.5.0.3 released...
13 April 2014 - PtokaX 0.5.0.2 released...
23 March 2014 - PtokaX testing version 0.5.0.1 build 454 is available.
04 March 2014 - PtokaX.org sites were temporary down because of DDOS attacks and issues with hosting service provider.

Main Menu

Recent posts

#1
Finished Scripts / Re: imdb rating/vote only offl...
Last post by WarrenWilliams - 27 February, 2024, 10:21:46
It seems to me that the fastest way is to download it from the homepage. Watch movies with the best quality and most diverse genres.
#2
Support / Re: Cannot connect from the In...
Last post by FloranceNice - 19 February, 2024, 17:49:47
Quote from: gadiscz on 08 December, 2023, 07:41:01Hi, I started PtokaX, but I can only download the file list between people who are on the same network, either on the local network or on the company network, but they must be the same, but both groups cannot establish a connection with each other, as if the router is preventing it, but I have both ports enabled Both 411 and 1209 and telnet connect from the Internet to the PtokaX server.

What else can block it? I have FW turned off on the router. also in PC

I have no idea related to this, but I am also looking for this thing.
Hope someone will answer this soon.
#3
Support / Cannot connect from the Intern...
Last post by gadiscz - 08 December, 2023, 07:41:01
Hi, I started PtokaX, but I can only download the file list between people who are on the same network, either on the local network or on the company network, but they must be the same, but both groups cannot establish a connection with each other, as if the router is preventing it, but I have both ports enabled Both 411 and 1209 and telnet connect from the Internet to the PtokaX server.

What else can block it? I have FW turned off on the router. also in PC
#4
Support / Re: Old Noob Needs Help
Last post by the-master - 13 November, 2023, 10:26:29
Thats not your clients fault, you enteredt the hub with LAN IP(wrong IP), a welknown mistake and causing a lot of ddos etc from older hubsofts, check settings on your clients profile, hubsoft should stop checking your profile.
#5
Support / Old Noob Needs Help
Last post by woollarding - 25 September, 2023, 18:15:53
Hello everyone.. hope someone still checks this place.

I am trying to set up a hub to use with friends, and it's been a long time since i hosted one of these. Most things are working and coming back to me but im getting an error i remember but cannot recall how to fix this and searching isn't helping much so maybe someone here will be able to assist.

I have my client on one computer and the hub on another. When i log in with my DC client it says

[11:52:06] <PtokaX> Your client send incorrect IP 'x.x.x.x' in command, hub replaced it with your real IP 10.0.0.220 !

i have tried several settings on the client but am still getting the message, do i just ignore it or is there a way to resolve that?

not an emergency but any help is much appreciated
#6
Extensions for PtokaX Lua / Re: lzlib 0.4-work3
Last post by PPK - 04 July, 2023, 16:04:10
Version for PtokaX 0.5.3.0 build 567 and higher.

Homepage: https://github.com/LuaDist/lzlib

Binary: http://www.ptokax.org/files/Libs-567/lzlib-0.4-work3.7z
Source: http://www.ptokax.org/files/Libs-567/lzlib-0.4-work3-src.7z

Initializing:
Code: Lua
local lzlib = require "lzlib"

This will create lzlib metatable, more is in readme :)

This library is compatible with PtokaX Lua 5.1.x, 5.4.x
#7
Extensions for PtokaX Lua / LuaSQLite3 0.9.6 / SQLite 3.42...
Last post by PPK - 04 July, 2023, 16:01:45
Version for PtokaX 0.5.3.0 build 567 and higher.

Homepage: http://lua.sqlite.org/

Binary: http://www.ptokax.org/files/Libs-567/LuaSQLite3-0.9.6-sqlite-3.42.0.7z
Source: http://www.ptokax.org/files/Libs-567/LuaSQLite3-0.9.6-sqlite-3.42.0-src.7z

Initializing:
Code: Lua
local sqlite3 = require "lsqlite3"

This will register global sqlite3, more is in docs 8)

This library is compatible with PtokaX Lua 5.1.x, 5.4.x
#8
Extensions for PtokaX Lua / LuaSocket 3.1.0
Last post by PPK - 04 July, 2023, 15:59:37
Version for PtokaX 0.5.3.0 build 567 and higher.

Homepage: https://github.com/lunarmodules/luasocket

Binary: http://www.ptokax.org/files/Libs-567/LuaSocket-3.1.0.7z
Source: http://www.ptokax.org/files/Libs-567/LuaSocket-3.1.0-src.7z

Iinitializing:
Code: Lua
local socket = require "socket"
local mime = require "mime"

This will create socket and mime metatable, more is in docs 8)

This library is compatible with PtokaX Lua 5.1.x, 5.4.x
#9
Extensions for PtokaX Lua / MD5 1.3
Last post by PPK - 04 July, 2023, 15:57:12
Version for PtokaX 0.5.3.0 build 567 and higher.

Homepage: https://github.com/lunarmodules/md5

Binary: http://www.ptokax.org/files/Libs-567/MD5-1.3.7z
Source: http://www.ptokax.org/files/Libs-567/MD5-1.3-src.7z

Initializing:
Code: Lua
local md5 = require "md5"
local des56 = require "des56"

This will register globals md5 and des56, more is in docs :)

This library is compatible with PtokaX Lua 5.1.x, 5.4.x
#10
Extensions for PtokaX Lua / Lua-Iconv 7 / win-iconv 0.0.8
Last post by PPK - 04 July, 2023, 15:54:42
Updated Lua-iconv 7 for PtokaX 0.5.3.0 build 567 and higher.

Homepage: https://github.com/ittner/lua-iconv

Binary: http://www.ptokax.org/files/Libs-567/Lua-Iconv-7.7z
Source: http://www.ptokax.org/files/Libs-567/Lua-Iconv-7-src.7z

Initializing:
Code: Lua
local iconv = require "iconv"

This will create iconv metatable, more is in README 8)

This library is compatible with PtokaX Lua 5.1.x, 5.4.x
SMF spam blocked by CleanTalk