Author Topic: [code] tag issues  (Read 4921 times)

0 Members and 1 Guest are viewing this topic.

Offline Rob Slob

  • Junior Member
  • **
  • Posts: 13
  • Karma: +6/-0
[code] tag issues
« on: 23 August, 2006, 11:45:12 »
Can you make it as a code so i can copy and paste?
and thanks American Idiot!
« Last Edit: 24 August, 2006, 12:39:41 by bastya_elvtars »
There he goes. One of God's own prototypes. Some kind of high powered mutant never even considered for mass production. Too weird to live, and too rare to die.

PtokaX forum

[code] tag issues
« on: 23 August, 2006, 11:45:12 »

Herodes

  • Guest
Re: Report
« Reply #1 on: 23 August, 2006, 11:53:33 »
Can you make it as a code so i can copy and paste?
and thanks American Idiot!
You can go into quote for that post and copy the code from there...

Offline Rob Slob

  • Junior Member
  • **
  • Posts: 13
  • Karma: +6/-0
Re: Report
« Reply #2 on: 23 August, 2006, 12:44:02 »
Thanks!
There he goes. One of God's own prototypes. Some kind of high powered mutant never even considered for mass production. Too weird to live, and too rare to die.

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 730
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
Re: Report
« Reply #3 on: 23 August, 2006, 12:47:29 »
You can go into quote for that post and copy the code from there...

Bah, the plain [c0de] thingy needs fixing, it parses HTML notations. The GeSHi isue cannot be fixed, that's an IE flaw, or all other browsers are buggy. :-P (The latter is the opinion of Steve Ballmer, MS CEO. :D)
Everything could have been anything else and it would have just as much meaning.

Offline Psycho_Chihuahua

  • Systemspecialist IT
  • Emperor
  • **
  • Posts: 1 054
  • Karma: +112/-1
  • I am wherever i want to be
    • PtokaX Luaboard
Re: Report
« Reply #4 on: 23 August, 2006, 18:27:17 »
well both [c0de] and [c0de=lua] seem fine with FF.
PtokaxWiki ?PtokaX Mirror + latest Libs

01100001011011000111001101101111001000000110101101101110011011110111011101101110001000000110000101110011001000000101010001101111011010110110111101101100011011110111001101101000

Offline Psycho_Chihuahua

  • Systemspecialist IT
  • Emperor
  • **
  • Posts: 1 054
  • Karma: +112/-1
  • I am wherever i want to be
    • PtokaX Luaboard
Re: Report
« Reply #5 on: 24 August, 2006, 08:44:29 »
[read: bastya, I just sat remotely
and moaned]

LooooooL
PtokaxWiki ?PtokaX Mirror + latest Libs

01100001011011000111001101101111001000000110101101101110011011110111011101101110001000000110000101110011001000000101010001101111011010110110111101101100011011110111001101101000

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 730
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
Re: [code] tag issues
« Reply #6 on: 24 August, 2006, 12:43:06 »
Bastya and I [read: bastya, I just sat remotely
and moaned] had  some time in finding the php code
to correct this on a former version of this board.

No, that was an issue when php added escapes to the code, this is something different.
Everything could have been anything else and it would have just as much meaning.

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 730
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
Re: [code] tag issues
« Reply #7 on: 27 August, 2006, 16:40:18 »
LOL, on simplemachines.org they deleted my thread on this, because I linked an example from another forum engine, a guy did a post saying that's not even SMF, then I told him that I can distinguish between forum engines, even though I am not a PHP ?berh4xx0r!!!!111~~~~~~~~~, and suggested him to try understanding my post first.
Kudos for the best support team ever!
Everything could have been anything else and it would have just as much meaning.

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 730
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
Re: [code] tag issues
« Reply #8 on: 27 August, 2006, 16:55:37 »
It's much the same thing dude, with respect to what the script does with the code text input.
Code should be regarded as 'pre' is in html markup.

One is magic quotes, the other is addslashes(). The latter was needed to avoid f*ckup with mysql injections. See this topic.
Everything could have been anything else and it would have just as much meaning.

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 730
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
Re: [code] tag issues
« Reply #9 on: 27 August, 2006, 20:07:09 »
Well to me it seems the problem stems from the Geshi mod.

SMF 1.1 RC3 does not have this problem with code. Nor did 1.08
Food for thought.

GeSHi does not alter the original [c0de] tags AFAIK. I'll try upgrading to RC3.
Everything could have been anything else and it would have just as much meaning.

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 730
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
Re: [code] tag issues
« Reply #10 on: 27 August, 2006, 20:47:51 »
Upgraded, does not help.
Everything could have been anything else and it would have just as much meaning.

PtokaX forum

Re: [code] tag issues
« Reply #10 on: 27 August, 2006, 20:47:51 »