[PLZ Help] Help with Sharechecker v1.4 by Leun and TTB

[PLZ Help] Help with Sharechecker v1.4 by Leun and TTB

Started by miago, 19 March, 2007, 09:39:22

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi guys.
I think this script needs a conversion since I get som errormsgs in ptokax. Havent used it for a while, but I like the script.

When users logs in:
\\scripts\leechers.lua:429: attempt to index global 'check' (a nil value)
and at the same time the check.dat file gets cleaned out. There was data in it, but when user logs in it gets empty.

When master try #leechers command:\scripts\leechers.lua:271: attempt to call a nil value
must be because the file is empty?
Tried even without any users logged in, and the file contained data, but nothing happened.

The script was too long to paste in codefield so I attached it.

At the same time, I was wondering, where in the script can I change the message that goes to the user if he/she is a leecher?

And three small requests also  :) :
Can somebody help me add rightclick commands (option to set by profile)?
Is it possible to make msg to user as an option (like on/off)?
Can the msg be sent to opchat when a leecher-user logs in?

Thanx in advance


Edit: Hi again. Have I put this in the wrong thread   ???  or is it that no1 is up for this?
I have looked around for a similar script but havent found any that I feel works the same. Thankful if U could tell me if I should close this thread.
//Miago again  :)

Have fixed it by myself =D
Found the converterapps and it works like a clockwork. (http://forum.ptokax.org/index.php?topic=6254.0)

The lines just above here was what I thought worked after the simple convert I did with the apps...but it doesnt..so keep on looking down in the thread...   :-\ 
Being a biatch aint easy ;)


I don't have time to realize your wishes at short notice... Maybe Leun can. I'll keep it in mind, and will check this later when I have time. If someone else wants to update it... feel free to do it!

(? ?.??.-> Admin @ Surfnet hubs <-.??.???)



Tomorrow/tonight i've got time. I wil give it a try then :-)

Morning miago,

In the attatchment you wil find a small update to lua 5.1.
I haven't test it, because I've got not an internet connection at my temporary home.
(I'me doing a training periode for my school atm.)
So if you find any bugs please post them :-).

All your three request are filled in this update, you can set up them in the Settings.



Thx...gonna try it immediatly...the one I tried after converting didnt work at all, at first I thought so but I was out riding my bycicle.

Thx for the work...gonna reply how it goes...

//Miago =D
Hi there Leun and all you other too :D

Found two things.

1. sharechecker1.5.lua:78: function arguments expected near ','  (I tried to add after () GetOpChatName and it seems to work, but Im not a scripter so maybe its wrong :))

next one

2. sharechecker1.5.lua:139: ')' expected near '"llist"'
the row is this:
         if cmd and (cmd=="..tSettings.sPrefix..""llist") then

this one I have no idea what to do with, so I hope U'll find the time to help me.
Maybe there will be more of the same kind, opened the lua in notepad++ and the variable in many lines
is greyed out (just like the above, ..tSettings.sPrefix..) and by the little I understand they should
be in black. Can see some black further down..
(Im trying to learn whilst U all guys help me =))

Being a biatch aint easy ;)


OK, syntactically alright now, post further errors if any.
Everything could have been anything else and it would have just as much meaning.


Thx for the very very fast help =D

Got this:

sharechecker1.5_fixed.lua:319: attempt to index global 'user' (a nil value)

and the row contains this:

317: tShareCheck.RC = function(curUser)
318:   if curUser then
319:      user:SendData("$UserCommand 1 3 ShareCheck\\Leech userstats$<%[mynick]> "..tSettings.sPrefix.."llist %[nick]&#124")

As I understand, maybe it should say  curUser:SendData.....??....as I said, trying to improve my little knowledge on this lua-thingy  :D

Being a biatch aint easy ;)


Everything could have been anything else and it would have just as much meaning.


Oki, done that, but it doesn't work...

When I rightclick on "leechers userstats" nothings happen...I have a testuser that has logged in about 5 times, but no info is put in the check.dat file in the scripts folder.
When I try the help under rightclick I get this:

[19:36:35] <-Hub-bot-> User &#124<-[TEST]-admin> is not in list!

Is there maybe a   ;| after 124  missing in the end of each of the rc-rows?
      curUser:SendData("$UserCommand 1 3 ShareCheck\\Leech userstats$<%[mynick]> "..tSettings.sPrefix.."llist %[nick]&#124")

No errormsgs in ptokax...but seems strange that no data is filled in the dat-file when the reg-user logs in...

Plz help =D

//Thankfully Miago
Me again..

The RC works after I put the ;| in th end of each row..
      curUser:SendData("$UserCommand 1 3 ShareCheck\\Leech userstats$<%[mynick]> "..tSettings.sPrefix.."llist %[nick]&#124;|")
and so on...

But the check.dat file doesnt fill up with info from users who log in...
Being a biatch aint easy ;)


You fixed it almost by yourself, I don?t see the bug right now, but I?ll test it in the weekend, or maby anyone else can fix it, sooner




Tried this once again on another puter, and now it works fine, the check.dat file gets filled with info =)
so I think there's  no more need for digging the head down in this script.

I thank U so much for the help I've been given

Being a biatch aint easy ;)

SMF spam blocked by CleanTalk