Author Topic: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]  (Read 16881 times)

0 Members and 1 Guest are viewing this topic.

Offline jiten

  • Scripter
  • Forum Legend
  • ******
  • Posts: 1 577
  • Karma: +71/-5
Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« on: 23 December, 2007, 11:59:26 »
Code: [Select]
--[[

Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2] by jiten
?????????????????????????????????????????????????????????????
Thanks to Dessamator, GeceBekcisi and T?M??r?V?ll?R for your contribution to this script

RECENT CHANGELOG:
?????????????????
- Fixed: Ancient timer bug - reported by Josecar (10/16/2007)
- Changed: Script converted to API 2 (10/16/2007)

]]--

PtokaX forum

Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« on: 23 December, 2007, 11:59:26 »

Offline Hemarr

  • Junior Member
  • **
  • Posts: 24
  • Karma: +4/-3
  • Ptokax LUA Rocks
    • LuLuMarr Games
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #1 on: 15 January, 2008, 22:57:36 »
awesome script just one thing it also get legal talk like these


Control: <[BG]ZloboMiR> (195.234.85.220) said in Main Chat: magnetic - Triggered by: net
Control: <Warrior> (84.32.229.189) said to <tomasito> this: Gal zynaj lietuviskus Hubus? - Triggered by: hub
Control: <Mig29> (78.60.21.189) said to <{NYC}Trivia> this: i want ti join your hub - Triggered by: hub
Control: <ruby> (77.49.125.84) said to <HX_LV> this: can u give me one slot please? I only need 200mb to complete this file...thanks - Triggered by: com


it warns users asking to join hub it picks up words like 
 <Mig29> (78.60.21.189) said to <{NYC}Trivia> this: i want ti join your hub - Triggered by: hub

also the word complete has the word com in it

ruby> (77.49.125.84) said to <HX_LV> this: can u give me one slot please? I only need 200mb to complete this file...thanks - Triggered by: com


should not pick up words on a regular conversation

should it not be

.com
.net

and so on?

is there a modified version?

Offline Gnuff?

  • Double Ace
  • *
  • Posts: 121
  • Karma: +21/-1
    • ?????Gnuff?s Hideout??????
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #2 on: 16 January, 2008, 06:35:39 »

should it not be

.com
.net

and so on?


Well, there are only 4 words under control, you could delete the words you don?t want, and add some new as you please.

Your rightclick commands makes that easy
Gnuff

imb

  • Guest
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #3 on: 17 January, 2008, 16:40:53 »
Hemarr You're expecting a computer to have the intelligence of a human here :) You need to adjust the key words to something more specific. For example remove the .com and add www. for websites and no-ip.com or dyndns.org instead for hubs.
« Last Edit: 17 January, 2008, 20:50:11 by imb »

Offline ?[-?Genius?-]?

  • Double Ace
  • *
  • Posts: 118
  • Karma: +3/-1
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #4 on: 05 February, 2008, 06:20:15 »
Hi

Its possible remove rightclick option?

Offline speedX

  • Lord
  • ***
  • Posts: 437
  • Karma: +59/-19
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #5 on: 05 February, 2008, 07:14:51 »
Hi

Its possible remove rightclick option?

Just delete the whole UserConnected function at line 187
Thanking You,

speedX

Offline -B-G-

  • Junior Member
  • **
  • Posts: 13
  • Karma: +0/-0
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #6 on: 31 March, 2008, 14:09:43 »
Hy all,i've a little problem with lucifer
 Lucifer 6.6.6 - Script Error: 03/31/08 12:58:56 - Lucifer6.6.6-build2.2[A2].lua:373: attempt to index field '?' (a nil value)
Do you know what's the problem?
Asus A8V deluxe - AMD Athlon64 x2 4200+ toledo @2804MHz - Zalman CNPS 7500 cu - 4x512Mb DDR - Sapphire Radeon x1950 pro 512Mb - Enermax liberty 500W

Offline jiten

  • Scripter
  • Forum Legend
  • ******
  • Posts: 1 577
  • Karma: +71/-5
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #7 on: 02 April, 2008, 17:56:31 »
Hy all,i've a little problem with lucifer
 Lucifer 6.6.6 - Script Error: 03/31/08 12:58:56 - Lucifer6.6.6-build2.2[A2].lua:373: attempt to index field '?' (a nil value)
Do you know what's the problem?

Can you paste me that line?

My guess is that the file where the trigs are stored is corrupted.

Offline -B-G-

  • Junior Member
  • **
  • Posts: 13
  • Karma: +0/-0
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #8 on: 03 April, 2008, 12:14:34 »
Thx jiten.I've solved the problem reinstalling lucifer.
The problem was in italian translation of right click command or in the file of trigs that i've changed.
In this moment is all ok with the original script.
Asus A8V deluxe - AMD Athlon64 x2 4200+ toledo @2804MHz - Zalman CNPS 7500 cu - 4x512Mb DDR - Sapphire Radeon x1950 pro 512Mb - Enermax liberty 500W

Offline BrotherBear

  • Triple Ace
  • **
  • Posts: 165
  • Karma: +20/-1
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #9 on: 09 August, 2008, 16:29:30 »
Hi Jiten!

I get this when I try Show Trigger Safe or anything else:

*** Syntax Error: !showtrig <safe/adver/control/site>

I am Running Ptokax 0.4.1.0 and Only The Lucifer Script.


Ahhh, found the problem, the file tLucifer.tbl must be in Ptokax Root folder or you change it in the script :)
« Last Edit: 09 August, 2008, 16:35:31 by BrotherBear »
Regards,

BrotherBear

Offline Dreams

  • Forum Ace
  • *****
  • Posts: 84
  • Karma: +1/-12
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #10 on: 28 February, 2010, 13:25:10 »
Is there a way to make it not trigger on other bots?

I have -Pm2Crew- and -Tips- bot, and when writing to this bot the lucifer script triggers the warning, pm sent into the 2 bots is sent to opschat , and this script shouldnt be trigger'd when conversation with op? so is there a way to make this not trigger those 2 bots?

For_Ever_MeXxX

  • Guest
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #11 on: 17 September, 2010, 08:15:55 »
I get this Error: 17.09.2010 09:05:34 - C:\PtokaX\scripts\Lucifer.lua:374: attempt to index field '?' (a nil value)

Code: [Select]
-- Site/safe checker
bFound = function(Lines, tTable)
    local Lines = Lines:lower()
    for value, i in pairs(tLucifer[tTable][1]) do  <~~ That is the Line 374.
        if Lines:find(value:lower(), 1, true) then
            return value
        end
    end
    return false
end

The Error started at the Time I used American Idiot's Reg Request.
I use PtokaX 4.1.1



SOLVED!
« Last Edit: 17 September, 2010, 14:35:09 by For_Ever_MeXxX »

Offline onkel

  • Junior Member
  • **
  • Posts: 18
  • Karma: +0/-0
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #12 on: 21 December, 2010, 12:37:54 »
[12:40] Syntax ...hubbbb\scripts\Lucifer6.6.6-build2.2[A2].lua:375: attempt to index field '?' (a nil value)


i get this error, why?

im using only this script atm .

Offline Aptem

  • Member
  • ***
  • Posts: 25
  • Karma: +1/-1
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #13 on: 21 December, 2010, 18:52:39 »
Code: [Select]
scripts\Lucifer6.6.6-build2.2[A2].lua:374: attempt to index field '?' (a nil value) ???

Offline Psycho_Chihuahua

  • Systemspecialist IT
  • Emperor
  • **
  • Posts: 1 054
  • Karma: +112/-1
  • I am wherever i want to be
    • PtokaX Luaboard
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #14 on: 21 December, 2010, 20:01:56 »
Code: [Select]
[12:40] Syntax ...hubbbb\scripts\Lucifer6.6.6-build2.2[A2].lua:375: attempt to index field '?' (a nil value)i get this error, why?
im using only this script atm .
Code: [Select]
scripts\Lucifer6.6.6-build2.2[A2].lua:374: attempt to index field '?' (a nil value) ???

if you guys took time to read a bit higher you would of found this...

Hy all,i've a little problem with lucifer
 Lucifer 6.6.6 - Script Error: 03/31/08 12:58:56 - Lucifer6.6.6-build2.2[A2].lua:373: attempt to index field '?' (a nil value)
Do you know what's the problem?
Thx jiten.I've solved the problem reinstalling lucifer.
The problem was in italian translation of right click command or in the file of trigs that i've changed.
In this moment is all ok with the original script.

most likely to be the same reason of error as you guys might be having
« Last Edit: 21 December, 2010, 20:03:57 by Psycho_Chihuahua »
PtokaxWiki ?PtokaX Mirror + latest Libs

01100001011011000111001101101111001000000110101101101110011011110111011101101110001000000110000101110011001000000101010001101111011010110110111101101100011011110111001101101000

Offline Aptem

  • Member
  • ***
  • Posts: 25
  • Karma: +1/-1
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #15 on: 22 December, 2010, 19:23:39 »
thanks, figured out a good script.
 ::)

Offline swedal

  • Junior Member
  • **
  • Posts: 18
  • Karma: +0/-0
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #16 on: 17 January, 2011, 14:05:02 »
hello i need a help with this scripts. how can i change this so only Owners can use this ? in right click i got the commands on all profile. please help me..

// Swedal

Offline TiMeTrAVelleR

  • Scripter
  • Lord
  • ******
  • Posts: 311
  • Karma: +19/-0
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #17 on: 17 January, 2011, 14:48:10 »
tLevels = {
         
  • = 1,
  • [1] = 1,
             [4] = 1,
             [5] = 1,
             [6] = 1,
          },


    change 1 to 0    restart script

Offline swedal

  • Junior Member
  • **
  • Posts: 18
  • Karma: +0/-0
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #18 on: 17 January, 2011, 20:46:13 »
tnx.. this is work very fine now. only Owner can use the commands..

tnx. :D

Offline swedal

  • Junior Member
  • **
  • Posts: 18
  • Karma: +0/-0
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #19 on: 19 January, 2011, 12:42:35 »
I has one qestion more. how can i setup in the scripts so Lucifer check the adversting for all user. no for masters and Owners. ??  now the scripts only check Reg users. no Vip  and higher.

// Swedal

For_Ever_MeXxX

  • Guest
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #20 on: 19 January, 2011, 17:38:48 »
Code: [Select]
--[[
Description: Profiles who can't send/receive "bad" messages and specific Action
Actions: [ 0 = Inform Ops (uncensored) / 1 = Silent (censored) / 2 = Warn / 3 = Disconnect / 4 = Kick / 5 = TimeBan / 6 = Ban ]
]]--
tBlockedProfiles = {

-- Example: [3] = 5, (Reg users are TimeBanned)

[-1] = 2, -- Unreg Users
[2] = 2, -- VIPs
[3] = 2, -- Regs
},

Offline Aptem

  • Member
  • ***
  • Posts: 25
  • Karma: +1/-1
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #21 on: 18 November, 2012, 18:12:55 »
Quote
        This is a Powerful AntiAdvertising Script
        Powered by Demone.Astaroth and OpiumVolage
        History: Base='multiline antiadvertise' by OpiumVolage (your tables simplify the work I did until that moment).
        Here its features:

        1)Script can block this types of advertisement: A) <user> example.no-ip.com
                      B) <user> e x a m p l e . n o - i p . c o m
                      C)<user>example.
                         <user>no-
                         <user>ip.
                         <user>com
                      D)<user>e
                         x
                         a
                         m
                         p
                         l
                         e
                         .
                         n
                         o
                         -
                         i
                         p
                         .
                         c
                         o
                         m
Hello, what code is responsible for this action, you can give me the code?

Offline Aptem

  • Member
  • ***
  • Posts: 25
  • Karma: +1/-1
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #22 on: 05 December, 2012, 18:17:39 »
Hello, what code is responsible for this action, you can give me the code?
HELP LPS!!!! :-[

Offline the-master

  • Triple Ace
  • **
  • Posts: 218
  • Karma: +10/-15
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #23 on: 06 December, 2012, 18:09:10 »
Download the script and you got it.. to easy?
keep on sharing :)
dchub://kickincountryhub.no-ip.org

Offline Aptem

  • Member
  • ***
  • Posts: 25
  • Karma: +1/-1
Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #24 on: 07 December, 2012, 12:30:07 »
Download the script and you got it.. to easy?
No, I do not need the entire script, I need a code which is responsible for the identification of this kind of spam

PtokaX forum

Re: Lucifer 6.6.6 [build 2.2] - LUA 5.1x [Strict][API 2]
« Reply #24 on: 07 December, 2012, 12:30:07 »