Author Topic: 0.4.0.0b  (Read 3383 times)

0 Members and 1 Guest are viewing this topic.

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 481
  • Karma: +209/-22
  • PtokaX developer
0.4.0.0b
« on: 11 March, 2008, 20:24:39 »
http://www.PtokaX.org/files/0.4.0.0b.7z

Quote from: Changes
Added: Hub name to PtokaX window caption.
Added: Max connected users limit from same IP + profile permission for that.
Added: Core.GetUsers returning online users with given IP.
Added: Minimum reconnect time + profile permission for that.
Fixed: Initial temp ban year in gui was always 2007 instead of actual year.
Rewriten: Nick hashtables (for userlist, reglist, nickbanlist) for better performance.
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

0.4.0.0b
« on: 11 March, 2008, 20:24:39 »

Offline Psycho_Chihuahua

  • Systemspecialist IT
  • Emperor
  • **
  • Posts: 1 054
  • Karma: +112/-1
  • I am wherever i want to be
    • PtokaX Luaboard
Re: 0.4.0.0b
« Reply #1 on: 11 March, 2008, 20:29:44 »
PtokaxWiki ?PtokaX Mirror + latest Libs

01100001011011000111001101101111001000000110101101101110011011110111011101101110001000000110000101110011001000000101010001101111011010110110111101101100011011110111001101101000

Offline Jusper

  • Junior Member
  • **
  • Posts: 18
  • Karma: +11/-1
Re: 0.4.0.0b
« Reply #2 on: 11 March, 2008, 23:27:42 »
useful things added. Thanx!

Offline baba.runner

  • Forum Ace
  • *****
  • Posts: 94
  • Karma: +16/-2
Re: 0.4.0.0b
« Reply #3 on: 17 March, 2008, 11:50:14 »
Hi PPK

I have alittle problem in 4.0.0b
I have alittle script for changeing temporarly the nicks in Mainchat and one of the first lines of the script is
Bot = SetMan.GetString(21)

Now when the hub is nor started and I tick the script in script-window I get this error:
attempt to index global 'SetMan' (a nil value)

When the Hub is started and I then tick the script, it works fine.

Is this now a PX problem or a scripting error. If it is a scripting error please tell me what I  have to change.

Thx in advance for your assistance.

KR
baba.runner

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 481
  • Karma: +209/-22
  • PtokaX developer
Re: 0.4.0.0b
« Reply #4 on: 17 March, 2008, 12:43:00 »
It is scripting error, don't use PtokaX api outside functions because when hub is not running then there is no api and script that is trying to call it outside functions showing errors.
In this case fix will be something like..
Code: [Select]
local Bot

function OnStartup()
    Bot = SetMan.GetString(21)
end
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline baba.runner

  • Forum Ace
  • *****
  • Posts: 94
  • Karma: +16/-2
Re: 0.4.0.0b
« Reply #5 on: 17 March, 2008, 13:16:36 »
It is scripting error, don't use PtokaX api outside functions because when hub is not running then there is no api and script that is trying to call it outside functions showing errors.
In this case fix will be something like..
Code: [Select]
local Bot

function OnStartup()
    Bot = SetMan.GetString(21)
end

Thank you very much PPK

that works fine now.

I toke the Lua5.1.1 script and converted it with Hungarista's converter. So I did not know about those issues.

Thank again.

Kind Regards baba.runner

PtokaX forum

Re: 0.4.0.0b
« Reply #5 on: 17 March, 2008, 13:16:36 »