Author Topic: Ptokax for linuz with older lua like 5.1.2?  (Read 2428 times)

0 Members and 1 Guest are viewing this topic.

Offline Hades

  • Triple Ace
  • **
  • Posts: 192
  • Karma: +2/-1
  • dchublist.org
    • United DC Hublist
Ptokax for linuz with older lua like 5.1.2?
« on: 07 March, 2009, 01:38:40 »
I really need a linux ptokax with lua 5.1.2 not higher as i have some scripts that wont run past lua 5.1.2. ALso old api i think if this matters.
Is there a chance to get it? Special biuld or something?

PtokaX forum

Ptokax for linuz with older lua like 5.1.2?
« on: 07 March, 2009, 01:38:40 »

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 478
  • Karma: +209/-22
  • PtokaX developer
Re: Ptokax for linuz with older lua like 5.1.2?
« Reply #1 on: 07 March, 2009, 02:08:49 »
All lua 5.1.x are same, so it is no problem to build PtokaX on linux with any of them. Old api is not linux compatible  ::)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline CrazyGuy

  • Viking
  • ****
  • Posts: 506
  • Karma: +83/-20
    • ?????=-_The NightHawk_-=?????
Re: Ptokax for linuz with older lua like 5.1.2?
« Reply #2 on: 07 March, 2009, 02:16:14 »
The changes between LUA 5.1.2 and LUA 5.1.3 are internal bugfixes. They have neither bearing on PtokaX, nor on the scripts written for these versions. If anything, scripts should perform better. Functionality has not changed

Offline Hades

  • Triple Ace
  • **
  • Posts: 192
  • Karma: +2/-1
  • dchublist.org
    • United DC Hublist
Re: Ptokax for linuz with older lua like 5.1.2?
« Reply #3 on: 07 March, 2009, 18:58:28 »
OK my fault!
I'm trying to run old good terminator by hawk it needs max lua 5.0 i think but somehow it runs on ptokax 3.6.0 with lua 5.1 to - confused!
Is there a way to compile latest ptokax 4.1.1 for unix with lua5.0?
Does new api matters in linux when it comes to terminator bot? sorry but have no idea about scripting.

Offline CrazyGuy

  • Viking
  • ****
  • Posts: 506
  • Karma: +83/-20
    • ?????=-_The NightHawk_-=?????
Re: Ptokax for linuz with older lua like 5.1.2?
« Reply #4 on: 08 March, 2009, 12:36:58 »
OK my fault!
I'm trying to run old good terminator by hawk it needs max lua 5.0 i think but somehow it runs on ptokax 3.6.0 with lua 5.1 to - confused!
Is there a way to compile latest ptokax 4.1.1 for unix with lua5.0?
Does new api matters in linux when it comes to terminator bot? sorry but have no idea about scripting.

Yes it does. Regardless of the actual LUA version being used, has the API changed dramatically.
You won't be able to run Terminator on any new-API PtokaX. And there is no old-API PtokaX for linux.
Your best bet is to wait for Madman to finish his Terminator v2, which will be compatible.

Offline Hades

  • Triple Ace
  • **
  • Posts: 192
  • Karma: +2/-1
  • dchublist.org
    • United DC Hublist
Re: Ptokax for linuz with older lua like 5.1.2?
« Reply #5 on: 09 March, 2009, 01:10:37 »
Oh that's a great news that MadMan is working on T2 - didn't know this script is still being developed .

THANX!

PtokaX forum

Re: Ptokax for linuz with older lua like 5.1.2?
« Reply #5 on: 09 March, 2009, 01:10:37 »