Author Topic: LuaExpat 1.2.0  (Read 1301 times)

0 Members and 1 Guest are viewing this topic.

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 480
  • Karma: +209/-22
  • PtokaX developer
LuaExpat 1.2.0
« on: 10 April, 2012, 16:25:05 »
Version for PtokaX 0.4.2.0 build 376 and higher.

Homepage: http://matthewwild.co.uk/projects/luaexpat/

Binary: http://www.PtokaX.org/files/Libs-376/LuaExpat-1.2.0.7z
Binary x64: http://www.PtokaX.org/files/Libs-376/LuaExpat-1.2.0-x64.7z
Source: http://www.PtokaX.org/files/Libs-376/LuaExpat-1.2.0-src.tar.gz

Initializing:
Code: [Select]
require "lxp"

This will register global lxp, more is in docs ::)

This lib is compatible with PXLua 5.1.5, 5.2.0 and 5.2.1 ;)

Update 8/May/2012:
  • Fixed: With Lua 5.2 lib now remain on top of stack after require, to restore Lua 5.1 behavior where lib was possible to load like local lxp = require "lxp"
  • Changed: Source is now packed with tar.gz to make it more friendly with non-windows OS ;)
« Last Edit: 17 June, 2012, 18:15:44 by PPK »
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

LuaExpat 1.2.0
« on: 10 April, 2012, 16:25:05 »