- RoboCop v4.0 - Testdrive 3 or Higher!


29 December 2022 - PtokaX (20th anniversary edition) released...
11 April 2017 - PtokaX released...
8 April 2015 Anti child and anti pedo pr0n scripts are not allowed anymore on this board!
28 September 2015 - PtokaX for Windows 10 IoT released...
3 September 2015 - PtokaX released...
16 August 2015 - PtokaX released...
1 August 2015 - Crowdfunding for ADC protocol support in PtokaX ended. Clearly nobody want ADC support...
30 June 2015 - PtokaX released...
30 April 2015 Crowdfunding for ADC protocol support in PtokaX
26 April 2015 New support hub!
20 February 2015 - PtokaX released...
13 April 2014 - PtokaX released...
23 March 2014 - PtokaX testing version build 454 is available.
04 March 2014 - PtokaX.org sites were temporary down because of DDOS attacks and issues with hosting service provider.

Main Menu

- RoboCop v4.0 - Testdrive 3 or Higher!

Started by Optimus, 12 October, 2003, 23:07:26

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


----------   ? R o b o C o p ?   ----------
v 4.0


  To install this script just unrar/unzip everything to the scripts directory...

  The Script uses the standard Profiles so no changes has to be made...
  Master has most previliges and REG least
  If you have installed a script that changes your Standard.Profiles then it's propably the best to Reinstall Ptokax Hub Software

  * Don't change the settings.ini unless you know how to. We recommend to use Robocop.exe for that.
  * Remove all Scripts make a fresh install
  * Features and Configs are to be set in Robocop.exe!!!
  * Save your Settings
  * Remember to -Restart Scripts-

  DON'T forget to change "Rules.txt" and "Network.txt" and "admessage.txt"


  The script uses a *.exe file called Robocop.exe to Configurate the script.
  If you are having problems running this file you have to download these libraryfiles.


  You just Install them to windows/system directory and done. (You Don't Have To Reboot After That!!) ;)  


Enjoy this new version and have a good time.... See you all soon again!



Keep up the good work m8

TiM? :P :]



No sleep tonight for me then  lol :D
thanks guys, i bet its cool !

Best regards


I think i'll have to download this later and have a look at it..


Thx Skrollster me allway's download yours to. it's been a great guide in the beginning off RC...

But this time RC is compiled so there ain't much to see. lol

bye all


Found a bug in Robocop

I put in share min 1 giga
and removed the min share from the ptokax console.

but when i woke up there where Mldonkey clients with 11mb in the hub.

How to solve it ?

now i solved it with put min share also in the ptokax console.

Greets Ac :)


Hi all

Thx AC me will look at it ASAP!

Greetingz me Optimus :]


**but when i woke up there where Mldonkey clients with 11mb in the hub.**

I know how to solve it!

Make it a mldonkey hub only,  lol
im sorry, its the coffee. makes me high.



Yups AC minshare is not working correct me checked it out. I will release a -Update- ASAP...

Thx and keep up the good work

Grtz Optimus


QuoteOriginally posted by Roy
**but when i woke up there where Mldonkey clients with 11mb in the hub.**

I know how to solve it!

Make it a mldonkey hub only,  lol
im sorry, its the coffee. makes me high.


LoooL Mldonkey rules :)


QuoteOriginally posted by Optimus
Yups AC minshare is not working correct me checked it out. I will release a -Update- ASAP...

Thx and keep up the good work

Grtz Optimus

ok i will test it again when its updated

Greets ac ;)


well done opti m8, as ever RoboCop keeps getting better,

           "ROCKIN SCRIPT"
>?Mm????L  N?tw??k????<


This command doesnt work ok:
!showreg       - Show the users from the selected profile (just !showreg will show all profiles)

Only !showreg works.............
But it say should work with !showop  etc....or im i wrong?

thanks for a great script.
Xion++ - Where it all begins


Hi all

Hai nice to have you back again m8

About your Question!

Syntax: !showreg reg, !showreg vip, !showreg op, !showreg master


Just !showreg for all aviable profiles!!!

Hope i did explained well hehe

By all & Greetingz Optimus


Just a quick question regarding the auto-repeating hub message:

- <>===========H=U=B==I=N=F=O===========
      ?Hub Owner: etc. etc.

The basic message and borders are now compiled into the script and so are unchangeable.

How do we decompile/recompile the script so we can change it?

I thought it would have been better to display the HubAdMessage.txt as we can edit it then :))
We came, we saw, we PtokaXed his ass :P


hello all, found problably a bug for robocop, but im not sure.
After i and my friend change to robocop 4, we are getting nicknames stuck somewhere when they try to log in.....it say nickname ar ere in use but they arent even in the hub.....

never had that problem before, now both of us got this problem, and only thing we did was changing robocop script.

maybe i need to test that nick already taken script, but is that really the problem? or is the script doing something?

keep up the good work  :)
Xion++ - Where it all begins


tooday i had an idea....to translate robocop 4 in italian....but....the main file of the bot it's coded!...There is no possibilty of translate it?

sorry for my english


Hi Boy's and Girls...

Me heard that before somewhere, don't think it's really a script bug. BUT?? if it is then i think it has some to do using !stealthmode. (just a wild guess)

Nope at this moment translation is not possible


i got the same problem as zinden and the only way to solve it is to reboot the computer, it only seems to happend to OPs or higer.
Here amid icebergs Rule I the nations This is my hammer, Mi?lner the mighty
Giants and sorcerers Cannot withstand it!


Hi guy's...

Let's see

It can be only 2 things...

1. nick allready taken is Ptokax hub software error
2. If you have used Stealth-mode then it can happen that your nick is allraedy taken..


If you have used !stealth and you got (Nick allready Taken) then it's the stealthmode. i will remove it then ASAP


Otherwise it's the same bug ass always that's caused by ptokax hub software

So please try to figure out when it's happening

Thx again Guy's will get there

btw, me waiting a few moments for update script until we know some more.

laterzzzz ;)


It happend me two days ago as admin, but i had a second dc++k as admin too and tried to restart scripts, but i still couldent get in. then i remotely restarted the hub using the !restarthub option and then i got back in.

i was not stealthed. but when that happened i was using 2 clients in the hub, question is does this happen also for those having only one client in the hub?


** update: Seems its the stealth mode that causes it. I stealthed then unsteathed logged out and couldent get back in, nick allready taken, can more ppl do tests on that maybe?

from black dc:

23:22] !stealth on
[23:22] *** Stealth mode is now enabled!
[23:22] !stealth off
[23:22] *** Stealth mode is now disabled!
[23:22] Connection Error: The Hub closed the connection.
[23:22] Disconnected from Hub.

[23:29] 192.168.123.XXX:226X > $Key ?¥???U7??VB?GS??VD0? ?B0qD???Q?e'??bP|
[23:29] 192.168.123.XXX:226X > $ValidateNick Gatekeeper[?8?]|
[23:29] 192.168.123.XXX:226X > $Version 1,0091|
[23:29] 192.168.123.XXX:226X > $BlackDC Ver:1.0r2,Bld:942|
[23:29] 192.168.123.XXX:226X > $GetNickList|
[23:29] 192.168.123.XXX:226X > $MyINFO $ALL Gatekeeper[?8?] Black D.C.  *BOT*$ $DSL$$0$|
[23:29] - User disconnected: Gatekeeper[?8?]
[23:29] - User disconnected: Gatekeeper[?8?]
[23:29] > $ConnectToMe Magensha|
[23:29] x User removed: Gatekeeper[?8?]

found a post about it in the finished script thread, nick allready taken script. but that script dient seem to help.

"PtokaX *** Nick already taken Bug




The problem occurs when a client is disconnected by the hub, commonly a break in his/her internet connection. When the client attempts to reconnect, PtokaX hub software responds with ?*** Your nick is taken? and will not allow the client to reconnect with that name. This is a great hinder to private hubs with only registered users.




DC Protocol does not use any communication to inform the hub that a client is still connected. When a client closes DC, a $Quit message is sent to all connected hubs to inform them that the user is leaving. So when a client is disconnected through hardware, the hub has no way of knowing that the client has disappeared, until the active TCP connection dies.


Recreating the problem:


This is as easy as connecting to a hub and then disconnecting by means of hardware. You could do this by turning off you router/modem or disconnected yourself from your network.




I recreated the problem and observed what happened through the windows console command ?netstat ?n?. The TCP connection never dies when a client reconnects to the network. In fact it stays alive for a very long duration (I tested for several hours until I got bored) never sending that necessary ?$Quit? message. So my DC client tries to make another connection using another port but receives the Nick because the ghost is still connected. This ghost connection remains active through private messages and get file list attempts. The connection can be killed through !drop and then removing the name from tempban, but this is tedious. To solve the problem, I addressed the issue of the user reconnecting with the same name that is a ghost, because after a period of time without reconnecting the ghost will be removed automatically.

I first set out to write a bot that would make a client to client connection whenever a person tried to connect to the hub with the same name. The plan was to write something with a timeout (say about 30 seconds) for the client to respond, otherwise they must be a ghost and the hub should drop the connection.

When developing this script, I discovered through testing phases that any data sent to a ghost directly eventually disconnects them. Viola! No need for my own timeout because it occurs automagically. The only problem left was what if someone wanted to flood the name with useless data to try to get it to disconnect. This is unlikely, but I implemented a limit to ensure it does not happen.


Final Remarks:


Most of my testing was down via a LAN, but after I had everything working this way I had people external to the network test everything. There is significant difference between the timeout on my LAN and everyone else I tested with. Everyone else?s ghost timed out in a little under a minute while on the LAN it occurred almost instantly. "


Any information or questions can be sent to cbarber@dwc.edu


hi roy how are you?

me was reading your post it was a long 1 haha

but it was a nice 1, there is a lot good info in it people will like that!

Conclusion is mostly the same as me i think... that ptokax hub software is not able to work with !stealth command... sadly but true i'm gone remove the !stealth command all must be fine then.

Btw, me must go check out that Black D.C client my self to... looks pretty amazing


Thx m8 & keep up the good work


Hehe, yw and the thanks goes to you, its a great script.

We like it very much.
And as allways, thanks for the replies, its great to communicate like this.




Fresh Board = Fresh Start.  haha

will do our best

Bye all

SMF spam blocked by CleanTalk