Author Topic: Post PtokaX DC Hub 0.3.3.21 bugs here!  (Read 45320 times)

0 Members and 1 Guest are viewing this topic.

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 479
  • Karma: +209/-22
  • PtokaX developer
(No subject)
« Reply #75 on: 11 September, 2005, 21:41:36 »
Quote
Originally posted by uffetjur
Application Title : PtokaX DC Hub 0.3.3.1 [debug]
:rolleyes:
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

PtokaX forum

(No subject)
« Reply #75 on: 11 September, 2005, 21:41:36 »

Offline Metaphase

  • Member
  • ***
  • Posts: 27
  • Karma: +1/-0
(No subject)
« Reply #76 on: 14 September, 2005, 13:40:20 »
Hi all.

I too am running PtokaX v0.3.3.21 Debug and have noticed a problem. For some unknown reason Users seem to be dropping from my hub and not coming back. This seems to be only happening to non registered users. I am not sure if this is a bug relating to PtokaX or not but I have noticed this alot...

Code: [Select]
[12:32] (62.72.232.171) > $Key tA 0PGaE%b#7Gb7p|
[12:32] (62.72.232.171) > $ValidateNick (BBB)Bedz|
[12:32] (BBB)Bedz (62.72.232.171) > $Version 1,0091|
[12:32] (BBB)Bedz (62.72.232.171) > $GetNickList|
[12:32] (BBB)Bedz (62.72.232.171) > $MyINFO $ALL (BBB)Bedz <++ V:0.674,M:P,H:50/0/0,S:10>$ $DSL$$12439217189$|
[COLOR=red][12:32] x User removed: (BBB)Bedz (Socket 536)[/COLOR]
[12:32] (217.209.190.180) > $Supports UserCommand NoGetINFO NoHello UserIP2 TTHSearch GetZBlock |
[12:32] (217.209.190.180) > $Key tA 0 pq%@V6fap|
[12:32] (217.209.190.180) > $ValidateNick sosa|
[12:32] sosa (217.209.190.180) > $Version 1,0091|
[12:32] sosa (217.209.190.180) > $GetNickList|
[12:32] sosa (217.209.190.180) > $MyINFO $ALL sosa <++ V:0.670,M:A,H:267/0/0,S:1>$ $LAN(T1)$$14450102485$|
[COLOR=red][12:32] x User removed: sosa (Socket 536)[/COLOR]
[12:33] x User removed: (Socket 536) [12:36] watje (62.194.248.241) > $Version 1,0091|
[12:36] watje (62.194.248.241) > $GetNickList|
[12:36] watje (62.194.248.241) > $MyINFO $ALL watje <++ V:0.674,M:P,H:41/0/0,S:1>$ $LAN(T1)$$11299620743$|
[COLOR=red][12:36] x User removed: grimmyboy (Socket 536)
[12:36] x User removed: watje (Socket 728)[/COLOR]
[12:36] (84.47.46.55) > $Supports UserCommand NoGetINFO NoHello UserIP2 TTHSearch GetZBlock |
[12:36] (84.47.46.55) > $Key tA 0s/%DCN096%//%DCN096%/Pue &!p|
[12:36] (84.47.46.55) > $ValidateNick lubo|
[12:36] lubo (84.47.46.55) > $Version 1,0091|
[12:36] lubo (84.47.46.55) > $GetNickList|
[12:36] lubo (84.47.46.55) > $MyINFO $ALL lubo lubmar<++ V:0.674,M:A,H:33/0/0,S:1>$ $28.8Kbps$hms@stonline.sk$0$|
[COLOR=red][12:36] x User removed: lubo (Socket 728)[/COLOR]

I know some of these Users are ok as they are able to enter my YnHub without any problems... ?(  My hub dropped around 50 decent users yesterday without any reasons as to why

Offline Pothead

  • Lord
  • ***
  • Posts: 455
  • Karma: +25/-4
(No subject)
« Reply #77 on: 14 September, 2005, 14:36:41 »
Quote
Originally posted by Metaphase
[12:32] (BBB)Bedz (62.72.232.171) > $MyINFO $ALL (BBB)Bedz <++ V:0.674,M:P,H:50/0/0,S:10>$ $DSL$$12439217189$|
[12:32] x User removed: (BBB)Bedz (Socket 536)
[12:32] sosa (217.209.190.180) > $MyINFO $ALL sosa <++ V:0.670,M:A,H:267/0/0,S:1>$ $LAN(T1)$$14450102485$|
[12:32] x User removed: sosa (Socket 536)
[12:36] watje (62.194.248.241) > $MyINFO $ALL watje <++ V:0.674,M:P,H:41/0/0,S:1>$ $LAN(T1)$$11299620743$|
[12:36] x User removed: watje (Socket 728)
[12:36] lubo (84.47.46.55) > $MyINFO $ALL lubo lubmar<++ V:0.674,M:A,H:33/0/0,S:1>$ $28.8Kbps$hms@stonline.sk$0$|
[12:36] x User removed: lubo (Socket 728)
Since they are being dropped straight after Myinfo string, i would assume, max hubs and /or min share.

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
PtokaX crashes many times
« Reply #78 on: 15 September, 2005, 23:15:55 »
I usually keep PtokaX minimized in SysTray like all the time. But I've noticed that from time to time it stop responding. I try to bring it on the desktop, to activate it clicking on the icon in the systray and it doesn't do anything. It just stand there. and it starts kicking silently all the users. I have to shut it down from the task manager and start it up again. I do not know if it is because of a script or what. That's why I'm posing the debug file so PPK can take a look on it. But it's too long to post here what can I do?. Thanks.

Debug file from the server

Offline hutchenky

  • Member
  • ***
  • Posts: 45
  • Karma: +0/-0
(No subject)
« Reply #79 on: 16 September, 2005, 00:27:53 »
---------------------------15-9-2005 19:23:50---------------------------
Exception 'EAccessViolation' in module ntdll.dll at 000112BA
Access violation at address 7C9122BA in module 'ntdll.dll'. Read of address 697550F8

Call stack:
:7C9122BA [ntdll.dll]
:7C911BDC [ntdll.dll]
:7C9186FB [ntdll.dll]
:7C910ECA [ntdll.dll]
:77D18BD9 [USER32.dll]
:0053336A [PtokaX.exe]
:005333EC [PtokaX.exe]
:00533843 [PtokaX.exe]
:00450024 [PtokaX.exe] clsUser::~clsUser (?p) (clsUser.cpp, line 164)
:004598A2 [PtokaX.exe] theLoop::ProcessAccepts (serviceLoop.cpp, line 115)
:00459F0F [PtokaX.exe] theLoop::FOnTimer (serviceLoop.cpp, line 235)
:00459F25 [PtokaX.exe] theLoop::FOnTimer (serviceLoop.cpp, line 236)
:0046E698 [PtokaX.exe] LuaInterpret::GetGC (luaInterface.cpp, line 4128)
:004A2B02 [PtokaX.exe] luaD_call (ldo.c, line 314)
:004AE829 [PtokaX.exe] f_call (lapi.c, line 672)
:004A2E6F [PtokaX.exe] luaD_pcall (ldo.c, line 416)
:004AE80C [PtokaX.exe] lua_call (lapi.c, line 657)
:004AA1A9 [PtokaX.exe] luaH_get (ltable.c, line 472)
:004AE88C [PtokaX.exe] lua_pcall (lapi.c, line 685)
:004AE80C [PtokaX.exe] lua_call (lapi.c, line 657)
:77D1EB3E [USER32.dll]
:746B0E6C [MSCTF.dll]
:00578B66 [PtokaX.exe]
:00578A4C [PtokaX.exe]
:0051AD66 [PtokaX.exe]
:77D18734 [USER32.dll]
:77D18816 [USER32.dll]
:77D189CD [USER32.dll]
:0051E5DF [PtokaX.exe]
:77D196C7 [USER32.dll]
:00575780 [PtokaX.exe]
:005757B7 [PtokaX.exe]
:005759D7 [PtokaX.exe]
:00575A1A [PtokaX.exe]
:00401B44 [PtokaX.exe] WinMain (PtokaX.cpp, line 43)
:005BE663 [PtokaX.exe]
:00400000 [PtokaX.exe]
:7C816D4F [kernel32.dll]
:7C8399F3 [kernel32.dll]

Main Thread ID = 00000EB8, Current Thread ID = 00000EB8
Registers:
EAX = 00000380  CS = 001B  EIP = 7C9122BA  Flags = 00010287
EBX = 00000881  SS = 0023  ESP = 0012FAA4    EBP = 0012FAB0
ECX = 0000037F  DS = 0023  ESI = 01780178    FS  = 003B
EDX = 69755100  ES = 0023  EDI = 01F50000    GS  = 0000
Code at CS:EIP
0F B7 5A F8 3B 5D 0C 72 07 8B C2 E9 01 FE FF FF
Stack:
01780000 00000AC2 01C29968 0012FAD4 7C911BDC
00000000 00000000 7C8399F3 00534A05 00E81D40
005FD30B 00DE5F68 0000000B 00000000 00E9A28C
7C8399F3 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF

Additional info:
Application Title : PtokaX DC Hub 0.3.3.0 build 17.08 [debug]
Major : 5
Minor : 1
Build : 2600
SP : 2
Type : 1
iJoins: 13505, iParts: 13345, iLogged: 160
NicklistLen : 1789
OplistLen   : 87
MyInfosLen  : 14305
MyInfosTagLen  : 14305
QueueA Size : 15
QueueA Len : 0
QueueB Size   : 15
QueueB Len   : 0
PQueue Size  : 183
PQueue Len  : 0
HQueueA Size  : 41
HQueueA Len  : 0
HQueueB Size  : 33
HQueueB Len  : 0
OPQueueA Size  : 372
OPQueueA Len  : 0
OPQueueB Size  : 651
OPQueueB Len  : 0
InfoQueue Size  : 197
InfoQueue Len  : 0
OQ-QueueA Size  : 229
OQ-QueueA Len  : 0
OQ-QueueB Size  : 65
OQ-QueueB Len  : 0

---------------------------15-9-2005 23:21:11---------------------------
Exception 'EAccessViolation' in module ntdll.dll at 00010E58
Access violation at address 7C911E58 in module 'ntdll.dll'. Read of address 656E2120

Call stack:
:7C911E58 [ntdll.dll]
:7C910D5C [ntdll.dll]
:7C90FB6C [ntdll.dll]
:7C90FB71 [ntdll.dll]
:7C809392 [kernel32.dll]
:7C8404F8 [kernel32.dll]
:00450024 [PtokaX.exe] clsUser::~clsUser () (clsUser.cpp, line 164)
:71A363AA [WS2_32.dll]
:71A38A1D [WS2_32.dll]
:0045319A [PtokaX.exe] classUsers::DisconnectAll (colUsers.cpp, line 180)
:7C90EAE3 [ntdll.dll]
:77D3E162 [USER32.dll]
:77D18734 [USER32.dll]
:77D18BD9 [USER32.dll]
:77D1885A [USER32.dll]
:77D1882A [USER32.dll]
:77D194BE [USER32.dll]
:77D1B42D [USER32.dll]
:00588205 [PtokaX.exe]
:77D184FC [USER32.dll]
:77D185A4 [USER32.dll]
:77D1B3F9 [USER32.dll]
:77D18BD9 [USER32.dll]
:77D1B3CC [USER32.dll]
Recursive call (2 times):
:77D1B3A7 [USER32.dll]
:773D2FFE [COMCTL32.DLL]
:77D1BA46 [USER32.dll]
:77D1BB0A [USER32.dll]
:5B19153D [uxtheme.dll]
:77D18734 [USER32.dll]
:77D18BD9 [USER32.dll]
:77D1885A [USER32.dll]
:77D1882A [USER32.dll]
:7C9105C8 [ntdll.dll]
:7C910551 [ntdll.dll]
:7C91056D [ntdll.dll]
:77D1882A [USER32.dll]
:77D1C63F [USER32.dll]
:7C910D5C [ntdll.dll]
:7C910F46 [ntdll.dll]
:7C910D5C [ntdll.dll]
:7C910E91 [ntdll.dll]
Recursive call (2 times):
:7C91056D [ntdll.dll]
:7C910D5C [ntdll.dll]
:7C910E91 [ntdll.dll]
:7C91056D [ntdll.dll]
:7C911902 [ntdll.dll]
:7C91056D [ntdll.dll]
:719D41C6 [MSWSOCK.dll]
:719D41D5 [MSWSOCK.dll]
:7C91056D [ntdll.dll]
:71A31384 [WS2_32.dll]
:71A396A4 [WS2_32.dll]
:0041AC9B [PtokaX.exe] ThubForm::StopServer (frmHub.cpp, line 2322)
:77D50577 [USER32.dll]
:77D5052F [USER32.dll]
:0041EB42 [PtokaX.exe] ThubForm::FormClose (frmHub.cpp, line 2862)
:0056EDB1 [PtokaX.exe]
:005722EA [PtokaX.exe]
:00571501 [PtokaX.exe]
:005715AD [PtokaX.exe]
:00428CAF [PtokaX.exe] ThubForm::Dispatch (frmHub.h, line 802)
:00582F3B [PtokaX.exe]
:746B09A9 [MSCTF.dll]
:77D318F4 [USER32.dll]
:77D1EA9E [USER32.dll]
Recursive call (2 times):
:77D1EAAD [USER32.dll]
:77D30210 [USER32.dll]
:77D30220 [USER32.dll]
:7C90EAE3 [ntdll.dll]
:77D318A2 [USER32.dll]
:77D3E185 [USER32.dll]
:77D3E162 [USER32.dll]
:10013086 [asOEHook.dll]
:100130A3 [asOEHook.dll]
:00585EE0 [PtokaX.exe]
:00F21360 [MsgPlusLoader.dll]
:0056F57A [PtokaX.exe]
:0041F95C [PtokaX.exe] ThubForm::PxWndProc (frmHub.cpp, line 3316)
:00585B5B [PtokaX.exe]
:0051AD66 [PtokaX.exe]
:77D18734 [USER32.dll]
:77D18816 [USER32.dll]
:77D318F4 [USER32.dll]
:77D1B4C0 [USER32.dll]
:77D1B50C [USER32.dll]
:7C90EAE3 [ntdll.dll]
:77D194BE [USER32.dll]
:77D1B42D [USER32.dll]
:77D184FC [USER32.dll]
:77D1BA0E [USER32.dll]
:77D184FC [USER32.dll]
:77D185A4 [USER32.dll]
:77D1D598 [USER32.dll]
:5B193C20 [uxtheme.dll]
:5B1AE300 [uxtheme.dll]
:5B191AC7 [uxtheme.dll]
:5B19367A [uxtheme.dll]
:5B1AE2D5 [uxtheme.dll]
:77D2F134 [USER32.dll]

Main Thread ID = 00000EB8, Current Thread ID = 00000EB8
Registers:
EAX = 01BFC730  CS = 001B  EIP = 7C911E58  Flags = 00010246
EBX = 01780000  SS = 0023  ESP = 0012EB20    EBP = 0012EB2C
ECX = 656E2120  DS = 0023  ESI = 01BFC728    FS  = 003B
EDX = 020F7218  ES = 0023  EDI = 01C06F60    GS  = 0000
Code at CS:EIP
8B 09 3B 4A 04 89 55 0C 0F 85 9D 00 00 00 3B C8
Stack:
01780000 01C06F60 00000001 0012EC00 7C910D5C
00000000 00000000 77D2F134 00534A05 00E12C08
005FD30B 018AC624 0000000B 00000000 00E33594
77D2F134 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF

Additional info:
Application Title : PtokaX DC Hub 0.3.3.0 build 17.08 [debug]
Major : 5
Minor : 1
Build : 2600
SP : 2
Type : 1
iJoins: 13505, iParts: 13381, iLogged: 124
NicklistLen : 1067
OplistLen   : 80
MyInfosLen  : 8247
MyInfosTagLen  : 8247
QueueA Size : 15
QueueA Len : 0
QueueB Size   : 15
QueueB Len   : 0
PQueue Size  : 183
PQueue Len  : 0
HQueueA Size  : 41
HQueueA Len  : 0
HQueueB Size  : 33
HQueueB Len  : 0
OPQueueA Size  : 372
OPQueueA Len  : 0
OPQueueB Size  : 651
OPQueueB Len  : 0
InfoQueue Size  : 197
InfoQueue Len  : 0
OQ-QueueA Size  : 229
OQ-QueueA Len  : 0
OQ-QueueB Size  : 1062
OQ-QueueB Len  : 1062

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 479
  • Karma: +209/-22
  • PtokaX developer
(No subject)
« Reply #80 on: 16 September, 2005, 01:41:58 »
Quote
Originally posted by Paco
That's why I'm posing the debug file so PPK can take a look on it.
In your debug file is crash from 3 and 4 september caused by script :rolleyes:
Quote
Originally posted by hutchenky
PtokaX DC Hub 0.3.3.0 build 17.08 [debug]
Name of thread is "Post PtokaX DC Hub 0.3.3.21 bugs here!" ;)
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
I know what you mean...
« Reply #81 on: 16 September, 2005, 06:27:11 »
I also tried to take a look inside and I also noticed theese dates but I really don't know what to tell you. maybe from PtpkaX point of view theese ar not crashes.
But I really don't know what to do in this situation that I've described you before.
When a program freezes and stops responding for me it's not clear what is the cause. First I thought it's probably the windows XP I'm using, but when the problem came back over and over again, I think maybe there is a problem when minimizing in systray, I don't know. What do you think?
« Last Edit: 16 September, 2005, 06:27:51 by Paco »

Offline PPK

  • Administrator
  • Emperor
  • *****
  • Posts: 1 479
  • Karma: +209/-22
  • PtokaX developer
(No subject)
« Reply #82 on: 16 September, 2005, 15:14:36 »
I found problem in 0.3.3.21 causin deadlock -> PtokaX freeze  :(
"Most of you are familiar with the virtues of a programmer. There are three, of course: laziness, impatience, and hubris." - Larry Wall

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
I changed something and i think i now now
« Reply #83 on: 16 September, 2005, 23:38:57 »
I didn't used now the options about minimizing in systray and it doesn't crash anymore.
I laso noticed that it has some problem when resizing. It does that very hard. I supose that this combined with restoring from systray could lead to a deadlock, an infinite operation or something. I am a vb programmer and i saw that before. Tell me if i'm right.

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
No dead-locks in almost 3 days
« Reply #84 on: 17 September, 2005, 18:13:34 »
I disabled the systray option and now I have almost 3 days since I normally use PtokaX without that option and I have to tell you PPK that it has no problem at all. I am now preety sure that it may come from there the dead-lock. Hope now you can figure it out yourself exactly the source. Thanks.

-----------------------------------------------
That was yesterday. I was really happy thinking that I had found the bug. But today it happened the same thing without beeing activated that systray option. Now i really don't know what to say. I'm confused.  ?(
« Last Edit: 18 September, 2005, 11:14:42 by Paco »

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
Once again today it crashed
« Reply #85 on: 18 September, 2005, 15:37:20 »
Today after almost 6 hours from the last crash it crashed again. I'm begining to be really concerned.
      I heard that PtokaX 0.326 testDrive is more crash free and I think I will downgrade this time.
      Only I want to ask if that version 0.326 accepts my LUA5 script that i'm using right now on 0.3321. That's all. Thks.

Offline Dessamator

  • Scripter
  • Emperor
  • ******
  • Posts: 1 262
  • Karma: +13/-9
(No subject)
« Reply #86 on: 18 September, 2005, 16:12:01 »
Nop. only versions above/equal to  0.330 have lua5 support.
« Last Edit: 18 September, 2005, 16:13:30 by Dessamator »
Ignorance is Bliss.

Offline blackwings

  • Scripter
  • King
  • ******
  • Posts: 986
  • Karma: +12/-8
(No subject)
« Reply #87 on: 18 September, 2005, 16:17:35 »
Quote
Originally posted by Paco
Today after almost 6 hours from the last crash it crashed again. I'm begining to be really concerned.
      I heard that PtokaX 0.326 testDrive is more crash free and I think I will downgrade this time.
      Only I want to ask if that version 0.326 accepts my LUA5 script that i'm using right now on 0.3321. That's all. Thks.
it must be a buggy script that causes your crashes.


Offline Pothead

  • Lord
  • ***
  • Posts: 455
  • Karma: +25/-4
(No subject)
« Reply #88 on: 18 September, 2005, 16:26:15 »
Quote
Originally posted by Paco
      I heard that PtokaX 0.326 testDrive is more crash free and I think I will downgrade this time.
That type of attiude doesn't help the developers in the slightest.
Quote
Originally posted by Paco
      Only I want to ask if that version 0.326 accepts my LUA5 script that i'm using right now on 0.3321. That's all. Thks.
***Edit *** Removed sarcastic comment, as i misread what Paco was asking for. :)
« Last Edit: 18 September, 2005, 17:43:21 by Pothead »

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 743
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
(No subject)
« Reply #89 on: 18 September, 2005, 17:32:08 »
Quote
Originally posted by Paco
Today after almost 6 hours from the last crash it crashed again. I'm begining to be really concerned.
Please post what scripts you are using. I am a medical student, and if i don't know which part of your body is painful, I cannot diagnose anything. Same goes here.
Quote
Originally posted by Paco
      I heard that PtokaX 0.326 testDrive is more crash free and I think I will downgrade this time.
OK, if you don't want to have topic support, want not to be on Hublist.org (since it does not support $BotINFO), want it to eat much more CPU and a lot more bandwidth, want to downgrade to lua4 versions of scripts and want not to be protected from flooders then feel free.
Quote
Originally posted by Paco
      Only I want to ask if that version 0.326 accepts my LUA5 script that i'm using right now on 0.3321. That's all. Thks.
A quote from Pothead: "Read the ChangeLog."
Everything could have been anything else and it would have just as much meaning.

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
Fair enough guys
« Reply #90 on: 19 September, 2005, 02:29:45 »
Ok it's fair enough.
---------------------------------------------------------------------
     I wasn't sarcastic at all my friends. It's not my style and beside I really apreciate PtokaX. I am said as you are every time something it's not working right.
      And yes downgrading doesn't help much a developer to progress in his work. But I don' t seem to pinpoint the problem and I need solutions, fast as I can not afford to restart server every 5-6 hours.
      As for the scripts if you are a medical student friend bastya_elvtars, I hope you cand find the cure, as my few knowledges doesn't allow me.
      For the sake of others PtokaX users I wish it would be a problematic script I messed up. Let's hope so. I'll try to post links to the script as soon as I upload them on a server.
---------------------------------------------------------------------
Thank you all for such short notice answears, because I know it was sunday. Thanks again

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
The scripts links
« Reply #91 on: 19 September, 2005, 02:49:11 »
I succeeded in uploading today the scripts on a server. All of them are coming from this board and are final versions as this date and as I recall. Here are the links:

Trivia Bot 0.6...

Censor Bot

CustomRandomIntroScript

List Profile

Clean Screen

Micro Chatrooms

OnlineFriends

WebStats
---------------------------------------------------------------------
I only hope you have the patience to look through. Some of them are really simple and dummy, others are more complex. Thanks for looking into it.

Offline Pothead

  • Lord
  • ***
  • Posts: 455
  • Karma: +25/-4
(No subject)
« Reply #92 on: 19 September, 2005, 02:52:49 »
Quote
Originally posted by Pothead
***Edit *** Removed sarcastic comment, as i misread what Paco was asking for. :)
Quote
Originally posted by Paco
     I wasn't sarcastic at all my friends.
I regret to say i was.  ?(  On reading bastya_elvtars's post i realised that you hadn't asked what i thought you asked, and i was un-necessarly harsh, so i edited my post. :)
« Last Edit: 19 September, 2005, 02:54:03 by Pothead »

Offline Northwind

  • Triple Ace
  • **
  • Posts: 213
  • Karma: +10/-2
(No subject)
« Reply #93 on: 19 September, 2005, 08:17:11 »
@Paco

Iam not a scripter but, i am wondering where are the credits from scripts... as we use scripts, we can keep those..
« Last Edit: 19 September, 2005, 08:19:43 by Northwind »


Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
I tried to delete all influence
« Reply #94 on: 19 September, 2005, 10:12:20 »
I knew that if I'll put inside version, author maybe bastya_elvtars will be influenced by that in analyzing a script or other, so I decided to post for him there just the code, as I completelly striped them of everything else as he should analyze the specific situation. I stripped even my coxde, that I've posted here about a Censor Bot.
      I didn't want to start discussions about a script or other, a version or other. The situation in its perspective is that interest me.
      I knew from the begining some of you will point me this aspect and I'm thanking you for that, but it wasn't, not even for one second a question of respecting or not the authors. I do respect them a lot as they do a great job every day, I just wanted to give you a chance of just analyzing the scripts without thinking of others aspects.
     Thanks and hope I'll have your understanding on this matter.

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 743
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
(No subject)
« Reply #95 on: 19 September, 2005, 12:54:01 »
Easy: disable the scripts one by one, and see what happens. I suggest disabling webstats and/or trivia.
Everything could have been anything else and it would have just as much meaning.

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
You are right, but...
« Reply #96 on: 19 September, 2005, 13:24:09 »
I thought you would say that my friend. I did something better. I deleted all the scripts and closed the server and then started again the server.

Last time it crashed I had only 2 scripts running: the TRIVIA BOT and the microchatrooms bot, as they are like essentials for me.

Personally i suspect trivia but i'm not well documented and i shall not make an acusation of such kind.

I have read many times here about strange bugs that even the best scripter couldn't understand. I'm hoping is not the case and I'm not dealing with a freaky bug.

Thks. bastya_elvtars for your advices.

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
After 2 hours it crashed again
« Reply #97 on: 19 September, 2005, 16:39:36 »
After 2 hours without nos scripts at all in the script list, and completely restarted it crashed again. People are sending me messages asking what happens and I'm really upset right now.
    What is weird is that for PtokaX this is not a crash, it just stops responding as it is doing something and needs time. But the situation continues forever. And in the debug file everything looks clean.
      PPK refered to a deadlock. It feels like it.
      The scripts are fine and I thank now to all their authors for understanding.
     Untill the problem will be resolved, I'll try to sort things out my way, keeping the server alive one way or another.
 Thanks guys for all your help so far.

Offline bastya_elvtars

  • Forum God
  • ****
  • Posts: 3 743
  • Karma: +173/-7
  • The rock n' roll doctor
    • The FreshStuff3 Site
(No subject)
« Reply #98 on: 19 September, 2005, 18:05:01 »
Quote
Originally posted by Paco
After 2 hours without nos scripts at all in the script list, and completely restarted it crashed again. People are sending me messages asking what happens and I'm really upset right now.
    What is weird is that for PtokaX this is not a crash, it just stops responding as it is doing something and needs time. But the situation continues forever. And in the debug file everything looks clean.
      PPK refered to a deadlock. It feels like it.
      The scripts are fine and I thank now to all their authors for understanding.
     Untill the problem will be resolved, I'll try to sort things out my way, keeping the server alive one way or another.
 Thanks guys for all your help so far.

What is the operating system? What is the machine architecture? What other proggies are you running?
Everything could have been anything else and it would have just as much meaning.

Offline Paco

  • Member
  • ***
  • Posts: 44
  • Karma: +0/-0
I expected that question...
« Reply #99 on: 19 September, 2005, 18:18:49 »
I'm running the server on a P4 3.2, 512 Gb. DDR2, Windows XP Pro SP2.
I am investigating as we are speaking if I have a problem with my windows. We shall see.
Since than still no ansewars, only questions.
What is curious is that I had no problems with few users (100 max.). Problems started when I started to receive 200+ users.
And other thing. All the time when Ptoka crashed I was logged in the hub using different clients. Now I'm trying to see what happens if I don't connect at all to the hub from this address.

PtokaX forum

I expected that question...
« Reply #99 on: 19 September, 2005, 18:18:49 »